Error: Max site size exceeded (104857600)


my site is:


I’m using a static site generator named “Publii” It worked fine so far.

But suddenly I get the error message:

An error occurred during connecting to the server: Max site size exceeded (104857600)

The message doesn’t make sense, because the site is quite small. Manual uploading works fine. My other sites still work fine.

Any ideas? Thanks for your help!

Seems they are sending filenames that have newlines in them - e.g. a file called:


That will lead to the error you see. You’ll need to either configure your site not to do that, or ask them for help in doing so.

Thanks for your reply. I don’t have newlines in file names.

I have the same problem now with another site. It was also discussed here
and here

The (clunky) workaround mentioned in the second post doesn’t work any longer because it isn’t possible to manually upload any more.

Any other ideas?

Yup, my suggestion is to again ask Publii to stop creating filenames like that.

well, the guys at Publii are pointing to the Netlify API. And that’s seems to be way more plausible because, as I said, there are no newlines in my filenames. I double-checked the output directory from Publii with the “find” command. It came up with nothing.


For your information - it seems that the issue was connected with missing “Content-type” header - I have got a backup of problematic website from one of the Publii users, and after applying the content-type header to the API requests the problem seems to be solved. In the upcoming week I will release Publii v.0.36.1 with a fix.

@fool - it would be great if the API responses in such cases will be more connected with the real reason of the issue :slight_smile:

Very much agree and I do have a bug filed on it :slight_smile: Thanks for finding the real root cause and applying a fix!

Hey there, we have the same issue. Can you tell me about solution for resolve it. Can we download a new version of Publii v.0.36.1? Thank you! Ross

Hey @rsipakov,

Still awaiting v.0.36.1. You can check in on that from the Publii repo.

For what’s it worth, you still have a misleading error message. I was this close to climbing up from the free tier to fix my quota issue :slight_smile:

In one of your other threads here, you said you’ll adjust the error messages, maybe this would help many others that do not report on the forums here.

Hi, @zladuric. Yes, the issue filed for this is still open (meaning it is unresolved). If/when the error message is known to be improved, we’ll post an update here (and any other topics where it was mentioned).

Think we shipped a fix for this so the error should never be thrown now. Please let us know by responding if you do see it, specifically:

Max site size exceeded