Disabling auto-publish doesn't work

Hi, I switched off auto-publishing for my website but it doesn’t seem to have worked and it keeps auto-publishing every push to the repository and adding deploy minutes to billing. How can I properly disable it?

hi Lukas,

can you share your netlify site name with us please, as well as a screenshot of your build settings?


autopublishing is just the act of turning a deploy live at your production URL. If you need building turned off, that is different and only our staff can do it at present, & we’ll be happy to help if you tell us your site name or ID.