Did anyone manage to test Netlify Dev with Vuejs

Hey there,

I tried using netlify dev --live today with a VueJS SPA I’m working on, but the app.js file doesn’t seem to be loading.

Has anyone tried the feature?


Can you elaborate on the issue you’re having? Also, have you tried running netlify init and running through that process?


1 Like

Hey, I remember you. From VueJS London :stuck_out_tongue:

So, i’ve tried that. The live url does not find app.js


Hey @larry1ths, is your repo public? Would it be okay to share with us?

Hi there,

I made one of my repos public for the purpose of testing: https://github.com/larry1ths/Maria-Larry-Shopping-App

Cool thanks! Will give it a try today. Unless it’s working for you now? :stuck_out_tongue:

Thank you! No it’s still not working for me.

Hi Larry,

Were you also getting this error when you run netlify dev or netlify dev --live?

      throw ex;

URIError: URI malformed
    at decodeURIComponent (<anonymous>)
    at Server.handler (/Users/Bluna/lunathecat-projects/netlify/netlify-dev-plugin/node_modules/static-server/server.js:140:26)
    at emitTwo (events.js:126:13)
    at Server.emit (events.js:214:7)
    at parserOnIncoming (_http_server.js:634:12)
    at HTTPParser.parserOnHeadersComplete (_http_common.js:117:17)

I tried removing the redirect rules and still getting the same error. Let me know if you had something different.

ok, I added a netlify.toml file with the following configuration and the dev server is working for me

  command = "yarn start" # Command to start your dev server
  port = 3999 # Port that the dev server will be listening on
  publish = "dist" # If you use a _redirect file, provide the path to your static content folder

I’m not seeing the live URL though. Sounds like you were able to see the live URL but the content wasn’t loading?

Hi Luna,

Thank you for trying this. Yes, I could see the live URL but app.js was not loading on that URL.

Neither netlify dev or netlify dev --live could open the app.js file :confused:

Did you try adding a netlify.toml file? I see the login page when I run netlify dev and app.js returns 200 after I added a toml file.

:confused: There is probably something with my computed I guess. Even with the netlify.toml file, app.js is not showing up as it should :confused:

Any chance you could push the changes you did to the repo to make it work? Thank you

Hi Larry,

Here you go https://github.com/lunaceee/Maria-Larry-Shopping-App

netlify dev works but neltify dev --live is not quite working. Got FATA[0000] invalid argument "undefined" for "-l, --local" flag: strconv.ParseInt: parsing "undefined": invalid syntax. Will investigate more when I got a chance.

Let me know if the dev server works for you.