Netlify cli `dev --live` resulting in a 404 url

PLEASE help us help you by writing a good post!

I’ve been using netlify dev --live to develop locally and share. However, recently the URL produced is now resulting in a 404.

I’ve tried restarting the computer and restarting the command multiple times but no luck in resolution. Please help.

Hi @uptownhr,

Could you share your repo?

Interesting, I was able to get it working (keeping the server on for a while):

EDIT: It does keep auto-reloading for some time though.

As I mentioned before, it was working for quite some time. A guess right now is that something on netlify DNS is not working and resulting in a 404. I think the live DNS that the CLI is giving is not actually adding in a DNS entry.

I’m pretty sure if I created a new site in netlify and connected the same repo it would work. Actually let me go and try that, but still something to investigate - since something did break with the site to cli integraiton.

I was able to address the issue by cloning the repo and starting from scratch. Although my git diff didn’t show anything, there must have been something i changed.

Cloning the repo and starting over isn’t a valid solution to this.

I am also experiencing this problem. The repo worked fine and now all of a sudden i’m getting an immediate 404 from netlify dev AND npm run dev. Any other repo I, have works fine to develop with

Basically I run netlify dev, everything looks fine, it opens up a website to localhost:8888 and it just says 404…

What can I try? I don’t know where to start. Right now I’m just pushing to a PR so netlify builds my site on a development branch, but if you can imagine this as SLOWED down development considerably without the local dev server.

Hi @JeffWScott

If netlify dev is loading localhost:8888 this is a local development instance, not a live instance (using the --live switch.)