Netlify dev shows a blank page with --live net::ERR_CONTENT_DECODING_FAILED 200

Works perfectly fine locally. Any ideas?
I’m running a Nuxt app

Do you have any public repository that we can try to reproduce with?

1 Like

Im having the same issue. Ive tried it with a couple of my repos and it doesnt work with any of them. I get a blank screen and the same error Failed to load resource: net::ERR_CONTENT_DECODING_FAILED for every repo Ive tried.
Here is a link to one of the repos.

hi @allygator, which command did you run? is it a standard create-react-app? It sounds like an issue handling gzip content.

note that Nuxt has known issues with netlify dev --live.

I have the same problem with a pretty basic react application that runs fine on the Netlify platform generally.

can you open an issue with a small repro? https://github.com/netlify/netlify-dev-plugin/issues

Anybody found the issue? I’m getting the same issue as @allygator mentioned.

Hi @judgeyboy, I don’t see that there was an issue filed. If you are still seeing the issue, I recommend that you file your issue here: https://github.com/netlify/cli/issues as mentioned previously. You’ll want to include a repro case, as well.

I revisited this issue today, and indeed got the same result, and googled it, and ended up here :woman_facepalming:

I did manage to “fix” it though, I changed the npm scripts to not do nuxt start anymore.
I changed it to be just nuxt

Now when running netlify dev --live the page loads a proxied version of my localhost with hot reload changes, which is VERY awesome! :clap:

P.S - redirects don’t seem to work at all, which is a topic for another discussion which I will post now

1 Like