Errors after trying a redirect url

It seemed thing were loading fine with netlify dev, so I tried a redirected url locally, which also worked since I saw it redirect, but then it jumped back to the root of the site and I I guess tried to reload the page since I then only got the basic html before any webpack js loads. Now it is no longer loading at the netlify dev localhost url, but the localhost url of the dev server its looking at does load. Its a vuejs/quasar SPA and shows console errors now ( even after restarting netlify dev at another port ) of Error: Loading chunk 0 failed & Uncaught SyntaxError: Unexpected token <.

Anyone have any idea on if something needs to be terminated still or what might be going on?

I’m on a mac.

1 Like

Seems I am able to get it to load again if I go back to leaving out my _redirects file ( I left out all my netlify related files so could be more to it )

Tried a fresh project and I believe I have narrowed it down to /* /index.html 200 in the _redirects. Commenting that one out on the larger project also allows it to load from netlify dev. It is the last one in the list.

Hi @shawn , it looks like you’ve been working iwth @swyx on this in slack. Let us know if you still need help.

Hey, I’m facing a similar problem with the /* /index.html 200 redirect causing netlify dev to serve index.html instead of a webpack generated js file (/bundle.js) even though the file exists. It works fine when I actually upload it to Netlify though.

@shawn, were you able to fix this?

@apappu9 No fix yet, but an issue is filed:

Any word on when this will see a fix released?

I’m seeing the same symptoms with this slight variation leading to the same result:
/ /movie-listings 200

(That’s a pretty URL, though specifying the file’s “.html” extension doesn’t change the outcome.)

While the workaround is mercifully trivial (once I found this thread), it sure would be nice to not think about it!

And thank you to those who found the workaround, I was beginning to question my sanity…

1 Like

I don’t think it’s been fixed yet, but I recommend adding your voice to the issue that @shawn linked to earlier