Deploying Site problem

Module not found: Error: Can’t resolve ‘@emotion/react’ in ‘/opt/build/repo/node_modules/@chakra-ui/css-reset/dist’

Hi @Rektovski :wave:t6: welcome to the forums! Can you provide the site name you are referring to ? Also please give this article a read as this will likely resolve your query this resource 7? It is a compilation of all of our build and deploy resources. This is a good starting point.

If those resources don’t get you on the right track, can you share a bit more information about what you are trying to accomplish?

Lastly, please share these additional details so we can look into your experience further:

  • the name of your build instance: “ 1
  • your project repo
  • a full copy of your latest deploy log
  • what you have tried
  • any error messages you have received in your terminal window or in the developer console

Thanks so much!

It worked now.

Here is story:

I’m doing frontend challenges from bitcamp. There are 14 challenges. 12/14 done. From 13rd I wanted to use Chakra UI CSS Framework. I added it. It worked.
I pushed it on git and forgot to check production.

Day 2

14/14, git push. done… aaaand Ta-daaam. I’ve found out, that there were some problems with chakra ui.

Netlify works perfectly at this point. Problem is with Chakra side.

Hmm, said I. :smiley: Adding little bit drama.

I rewrite routing system from netlify link to localhost ending with route link. It was working. This was the worst moment.


When you try to add chakra with npm or yarn you need to be sure that libraries that it must add in package.json > dependecnies are there.

For example you installed framer-motion. You need to check is it in package.json now or not. It is important… I tried to install all kind of stuff because of that.

Then, I just copied name of modules that were not in package.json from netlify error, chose the version manually. Manually because on local stage program sees that you have this libraries but hosting can’t. Maybe because it is globally installed. I don’t know.

Hi @Rektovski, thank you for the elaborate response and your troubleshoot steps. I appreciate the feedback and this will help other users who experience similar problems!

1 Like