So I am having issues deploying my github repo

So I am not being able to deploy and I was wondering where could I get more info about the error:

First of all since I am getting this:

Additionally, I believe I imported through the button importing an existing project.
Not sure if this is important: my versions →

npm: '8.1.2',
  node: '17.1.0'

@HerRA17 The error is as it says.

You have a file at src/index.scss which on line 4 contains a declaration of:

@import "~bootstrap/scss/bootstrap.scss"

When @parcel/transformer-sass is running it cannot find that stylesheet.

You should check the files and references to make sure they’re correct.

1 Like

Thanks, I will look in Stack Overflow or so. Because the app works perfectly locally. And I am not finding what exactly could cause that.

@HerRA17 When you say “works perfectly locally” do you mean the same build command you’re running on Netlify, or a different development command?

Often there are differences between the two modes, so you should run your build as close as you can to what you have set on Netlify on your own system to see if it’s actually Netlify introducing an issue, or just the difference between your two commands.

Noted. I mean locally if I run parcel src/index.html and I am able to see the project locally. I made a recent adjustment thinking of I possible error but I am not sure what could be the cause in Netifly that it does not build.

@HerRA17 Have you tried running your Build command locally?

It should be whatever you have set for Netlify either in your Basic build settings or netlify.toml file.

As you’re using parcel it will probably be something like parcel build src/index.html

Hi Nathan so as well I can not build my app with parcel, so I assume it is more a parcel issue.

@HerRA17 That’s correct, if your build command won’t work locally, then it also won’t work on Netlify.

It’s easiest to debug and fix issues locally and once it’s working try on Netlify again.

Main suggestion you could share would be to have a look as well on the exit code that netlify provides.
I am not finding the issue. And some colleagues have shared how they approach their fix path.

@HerRA17 I’m not sure what you’re suggesting as I don’t work for Netlify.

The exit codes are frequently useless as they’re not error specific.

1 Like

Sorry fro misinterpreting that. Good to know. I will just continue looking in the Forums. I am not really sure why it is not working for me.