The Build is Failing

Dear community,
I have a small react app created with “create-react-app” and it builds locally using the same node (10.19.0) and yarn (1.17.3) version as on Netlify (see log). For some reason, during the build on Netlify (triggered via netlify deploy and also manually) it cannot find a file which it should. I thought it might have something todo with the base url, which I tried with . ./ & / without success unfortunately.

My Netlify instance name, is:

I am at an end with this as I’ve tried and searched all afternoon. I hope there’s someone out there who can point me in the right direction, as I’m sure that I’m doing something wrong :slight_smile:

Any help is greatly appreciated

Cheers, Ben

Hi there, sorry you are having issues. I’m not 100% sure about this, but I am going to guess this might be a case issue. Do you have a file called Home.js or is it home.js? It needs to be home.js in order to work.

You might also check this thread for more information:

if you are still having issues and this doesn’t fix it, let us know.

Hi Perry, thank you for getting back to me. Here is the file structure I’ve gone for…hope I don’t have to adjust all :slight_smile:


Do you think there’s an issue with that?

edit: btw I cloned the repo to a new folder and built it there without an issue…so if would have been a case issue, it would have apparent.

Cheers, Ben

Hi Community

For anybody who happens to have the same issue in the future, I was able to “solve” this issue by renaming the Home folder. In my case, I changed it from “Home” to “Start” and it then magically worked…I still have no idea why, as it builds locally without an issue. Also, AFAIK, “Home” is not a reserved word, name or whatever so this is some black voodoo magic shizzle going on here…but there is an explanation for everything. So if YOU are reading this and have an explanation why “Home” folder is not allowed, please share :slight_smile: