Configure Site and Deploy - "Branch to deploy" gives alert "No results found"

Trying to deploy a new project from Github. When I am on the Configure Site and Deploy page the text states “deploy from main branch”.

When I try to fill in the Input field “Branch to deploy” I receive the alert “No results found”
Without being able to fill in this field, I am unable to continue and deploy the site.

How can I proceed?

Hi, can you check the following:

  1. Ensure that the repository is correctly linked to your Netlify account and that the repository contains the branch you’re trying to deploy.
  2. If the branch exists in your repository, try disconnecting and reconnecting your Github account to Netlify, as suggested in the forums.

Hi Sam. I’m also having the same problem as the original poster, where no option displays in the “branch to deploy.”

I must confess I’m new to coding in general so I’ve probably made a slip up along the way, but as you can see from the photos, my Github desktop app displays my current branch as main, which I understand is the more recent term for the master branch?

Any help would be very much appreciated.

Thanks in advance.

1 Like

Forgot to mention that I tried disconnecting and reconnecting my GitHub account, but to no avail…

The site is also working as intended locally on my computer.

Can you share your site name/slug? I also don’t see a screenshot. @Ryu

Hi Sam,

All solved now - I added, committed and then pushed the content to the main origin using the terminal instead of the desktop app.

I clicked publish using the app, which then blurred out the button so I assumed it had worked but obviously it hadn’t.

So to clarify the solution for anyone reading - just use the following commands in the terminal:

  • git add .
  • git commit -m " #comment something there that describes the change if you want "
  • git push -u origin main #main worked for me but perhaps it’s master for you