Checking DNS Settings between Netlify & Namecheap

Hi all, new here. I did try searching through forums but could not build a secure enough conclusion about whether or not my settings are correct on Namecheap for Netlify.

And I cannot use Netlify DNS as that messes up my Gmail MX records and txt records on Namecheap :confused:.

I have attached an image with my Namecheap records for Netlify. I THINK they are correct.

The Netlify domain settings also ‘suggest’ that everything looks OK. But the site is not loading. I have made these changes around 3 hours ago so perhaps it’s just a timing issue and I’m being impatient.

Could someone just confirm (or correct) if everything looks OK? I’d love to make some sort of documentation on this on my website. I think a lot of people will be switching away from Google Domains (Squarespace) to Namecheap, could be hella useful.

Appreciate any help,


Your setup is correct. Are you having any specific issue?

1 Like

Hi @hrishikesh, thanks for confirming.

Well, my website is not loading so that’s the issue I guess.

Was just wondering if my setup is correct and if this might just be a timing issue. I read about the 48hours waiting period all over the web, but if that was the case I would have expected Netlify to show some sort of “!” Message. Not the “Netlify DNS” with a tick.

Loads fine for me:

Sounds like a local DNS propagation issue.

1 Like

Oh! That’s really interesting. So a “local DNS” simply needs more time to be updated if i understand all of this correctly? If so, nice one! One more lesson before the week ends :slight_smile:

Thanks for confirming and checking everything hrishikesh, really appreciate it.

Based on the above discussion, and this article on how DNS Propagation works and what it is, I think I somewhat understand the core idea now.

Hi @hrishikesh,

How could I check if everything has propagated fully? And this is a new observation:

I have successfully accessed my site, in the UK, from my mobile phone. I can’t on any of my computers. I am wondering if this is a DNS issue or if I somehow ‘blacklisted’ myself. Lets say my FTP tries accessing the website with the “old data”. Is that something that could happen?

A friend mentioned this to me, why I’m asking.

Edit: I have also tried clearing my DNS cache on my Macbook.

I have an odd update.

In addition to using my mobile network to access the website, i can also access it whilst using a VPN set in the UK.

I searched the forums a bit and it seems that Netlify could be blocking my IP address somehow, is this possible?

Final update:

Not sure what finally worked in the end for me, could have simply been a DNS propagation issue, but I found out that waiting around 36 hours did the trick. It never happened before, needing to wait this long for a domain-related change, but now I know better.

Everything is working fine after the domain transfer.