Cannot Push from Working after installing Netlify LFS


I just implemented Netlify LFS on my blog ( I did the LFS install from the command line on my desktop and it went off without a hitch. Except…

I generally work from my iPad and push changes to my git repository using the git client (

Now, when I try to push changes in working copy, I get a dialog box saying “This endpoint requires an authorization header”.

I tried using my netlify login and my github login, but neither satisfy the box, which comes back saying it expected something in Base64.

Does using LFS mean I am doomed to push changes from my desktop, or is there a way to find the credentials I need to continue using

Thanks so much,

Will Puckett

1 Like

Hi, @willpuckett, in order for this git push to succeed the following things are required:

  • install Netlify CLI
  • install the Large Media plugin for Netlify CLI
  • enable the Git credential helper
  • log into your account using Netlify CLI

This all must be done on the device you are pushing from. I know very little about iPads and I don’t know if that list is achievable with that type of device.

If you have other questions about this, please let us know.

Hi @luke,

Thanks so much for the response. I’ve done a little more research and thought I’d share what I found here so that hopefully others struggling with this issue can find a reference point.

LFS (and Netlify LFS) does indeed work on Working To use it, one should follow the instructions you outlined above on a desktop/laptop/cloud vm, or, for those who need a little more detail, these instructions. Once LFS has been installed on Desktop and the repository has been successfully pushed to origin, it can be accessed via Working Copy.

From Anders (the developer):

The app is supposed to detect the Netlify LFS server and give you these special instructions:
“You need to supply a Netlify access token to access Large Media objects.
Look for a 64-hexdigit ‘token’ in ~/.netlify/config.json on a machine where the Netlify CLI is available.
Use this token as the password.”

Unfortunately, Anders was unaware of the change in Netlify domains from .com to .app, so Working Copy wasn’t detecting the need to prompt for the Netlify token.

Anders is now working to fix this and will have it working in the next update.

Thanks again!


1 Like

@willpuckett; thanks for posting this question-and-answer. I feel like this is the right first step, but I still can’t get Working Copy to accept my credentials.

I found the 64 hexdigit token in the spot where I expected to and plugged that in as the password, but what user name do I use? I tried using my Netlify user name, and also the userId from the same Netlify config file. In both cases i continued to get the error message “Expected the Base64 encoded string.” Any clue what mistake i am making?

Hi David,

Still waiting on the update. The current Working Copy version is 4.2.3 you’ll need the next version after that after it drops.


1 Like

Hi @davidrhoden,

Anders pushed 4.2.4 to the App Store yesterday, which includes the fix for domain names. You should be good to go.



Yes, cloning works now. Thanks for doing the research and sharing it here.