Git-push requires netlify credentials

I am trying to set up a second repo with Netlify Large Media.

When I try git push I get a request for netlify credentials. I log into netlify using GitHub credentials and these do not work for logging into Netlify on the CLI for some reason.

git push
Username for '':

I have checked my $PATH, it includes the netlify helper: /Users/<username>/.netlify/helper/bin

my PATH, my .lfsconfig, .netlify/state.json, .gitattributes all match another Large Media repo on my computer with the exception of the Netlify site ID, and different paths in .gitattributes

Not sure why this repo wants credentials I don’t have, while the the other repo does not.


Please help, can’t push


Seems like that might be related to our in-progress migration, @thewellington :

I’ve alerted the team who will try to work on a fix as soon as the migration is complete.

Hi @thewellington,

Can you post the content of .lfsconfig here? Make sure there is not passwords of any kind before doing so.

	url =

This is not a new site - it has been in place for some time. I am just enabling Large Media now.

hi there, thanks for that. We will take a look as soon as we are able. Apologies for for the disruption, but we’re glad to be alerted to this behaviour for Netlify Large Media! That is definitely helpful for us to know about :muscle:

Thanks for the information @thewellington.

It looks like you activated the feature right while we’re making a long coming change from to for internal subdomains. I’m very sorry for the disruption. You can read more details about this change in this other thread: Changes coming to Netlify site URLs

If you change in your lfs configuration to, it would work as expected.

1 Like

thx. I can do that. Will I need to do this for the other sites I have with LFS?


Actually that didn’t work either :frowning:

git push
Username for '':

hmm, that isn’t what we had expected! We are going to do a little digging and try and figure this out. We’ll get back to you here as soon as we can with more information or questions. Thanks again for your patience.

So, This left me in a pickle. I have changes I need to push to the site. So I commented out the stanza in .lfsconfig and I was able to push - expected.

However all my LFS media pushed to LFS - things seem to be working with the .lsconfig data commented out.

Can you explain that?


and all my graphics are broken

Hey @thewellington, we are actively working on this and hope to have a code change that’ll fix this published soon. I totally get that this is less than ideal - we’ll update you as soon as we have any news.

hi again @thewellington - thanks again for bringing this issue to our attention.

We believe we have located the source of the problem and applied a fix.

if you go ahead and run the command netlify lm:install you should receive the new version of the credential helper which should allow you to push successfully.

if you have further concerns, please let us know - once again, we apologize for the hiccup!

Well, that worked - sort of. I got the new credential helper, uncommented the .lfsconfig file, and was able to push. However I still don’t have any graphics showing up on the site.

yay, well, at least we were able to get one thing working!

As far as your broken images are concerned, I am seeing some inconsistencies you’d want to rule out first:

Here, you have an image with a space in the filename, which might be causing problems:

and slightly further down on the page, you are actually linking to a pdf file, as opposed to an image:

I’d go through your project and rule out that any of these broken images are being caused by issues unrelated to LFS first! :smiley:

all images are broken. and yeah there are some with spaces in them. but what about those without spaces.

Also those spaces worked before. do they not work with LFS?

those are good questions - it may be that something got a bit muddled up while you were troubleshooting earlier. The Support Engineer who knows most about LFS can take a look when he is back around, hopefully we can get you some definite answers by tomorrow.

As a general rule, any special character (and that includes spaces, which get treated like special characters when they are in filenames) are a no-no, really, as they don’t get handled well or consistently by filesystems, as a rule. We encourage all-lowercase and no spaces to minimize weird behaviour :+1:

Also somehow the process of this has put strange artifacts in many of my images

I think I now need to figure out how to undo all of this

So in the process of this, the repo history has been changed… right?

Like I can’t go back to a commit form yesterday and have this all undone?