Support Forums

Git-push requires netlify credentials

Following the netlify instructions has hosed my images and put me in a place I can’t get back from.

I am super disappointed

how do I get all my images out of the large media repository now?

EVERYTHING I put into large media is gone. It doesn’t show up not he websites and the copies on my computer were somehow damaged by this process.

hey there, I think all is not lost! As i said, we do have a support engineer who knows a lot more about LFS and I’ll ask him to see if this can be fixed. Don’t give up yet!

I am about an hour from doing just that. I need this solved as soon as possible

I need to get back to where I was this morning! I wish I had never heard of LFS I have to go back now

I need somebody who can walk me through those steps immediately

Alright, I have locked this thing to a deploy from yesterday. But my faith in large media and CI/CD has been shaken. If I can’t trust those things, then Netlify is useless to me, and instead I can just host the static site in S3. I need to talk to a support engineer and get steps to either get this working, or get out of Netlify. How do I set up a call?

Hi, @thewellington, I’ve sent you an email where we can troubleshoot this.

If you don’t receive that email, please reply here to let us know. Otherwise, please reply to the email we have sent about this and we’ll keep working on this issue there.

Hi! I’m sorry to open this issue again but after setting up Large Media in my site every time I try to git push I receive this:

git: 'credential-netlify' is not a git command. See 'git --help'.
Username for 'https://github.com': 

and I have to enter my username and password (after doing that git works). I was using Textmate and from there I cannot push anymore.
I’d appreciate any help, thanks!

Hi, @rodrigoalcarazdelaos, one of the steps of installing Large Media is adding something similar to the following to the .bash_profile (or .bashrc):

# git credential helper for Netlify CLI
. ~/.netlify/helper/path.bash.inc

I don’t know if enabling that will work for Textmate also or not. It will resolve the prompts for username/password in the shell (also known as the “command-line” or “terminal”). Depending on how Textmate is designed, it might fix the credential issue there as well.

Would you please try adding the git credential helper include line to .bash_profile and let us know if that resolves the issues or not?

1 Like

Hi @luke thanks for the response. I followed the step where a command starting with source was given to me:

(I’m using zsh). I have run that command but still nothing. Inspecting path.zsh.inc I see that it only has this line:

export PATH=${0:A:h}/bin:$PATH% 

Where should I put that line?

1 Like

Same problems here actually. Quite frustrating!

1 Like

Hi, @rodrigoalcarazdelaos and @f3rg. Based on this StackOverflow post, it would appear this should be added to ~/.zshenv.

Note,you need to add the source ~/.netlify/helper/path.zsh.inc line to your ~/.zshenv and not the export PATH=${0:A:h}/bin:$PATH% line.

With zsh, the shell varaible ${0:A:h} will return the current directory for the script so adding this line itself to ~/.zshenv would set this to ~/bin instead of ~/.netlify/helper/bin.

Did you run the “source” line of the “export” line? I ask because the export line itself won’t work.

I created a .zshenv file and added that line and even re-cloned my repository from scratch and followed this to cach my credentials but git is still asking for my username and password.

Hi, @rodrigoalcarazdelaos, would you please send us the three following details?

If so, the output of the three commands below would be helpful:

echo $PATH
netlify lm:info
netlify status

Output of echo $PATH:


Output of netlify lm:info:

Output of netlify status:

Just in case this sheds light on the matter, I just noticed an issue when trying to clone my repo from Github Desktop, something that doesn’t happen with the git clone command from the Terminal. It surely has to do with Git LFS, and perhaps with Netlify Large Media too

1 Like

Hi, @rodrigoalcarazdelaos, I’m stumped and I’ve asked our developers to take a look and assist with the troubleshooting here.

Someone will be following up here shortly. (Either our developers will reply directly or I will pass on their suggestions.)

We will have another reply here soon!

1 Like

I’m still making best guesses here and I don’t know why this is happening for your system. One thing that sticks out is the Git version: Git-128) (with a closing parenthesis).

This is what I get locally:

$ netlify lm:info
  ✔ Checking Git version [2.26.2]
  ✔ Checking Git LFS version [2.10.0]
  ✔ Checking Git LFS filters
  ✔ Checking Netlify's Git Credentials version [0.1.9]

I believe version “Git-128” is the stock Git client installed with MacOS (or maybe with Xcode). This might not be the same Git that the git credential helper is designed for and I don’t know if that version is supported or not. (I’m having trouble getting more information about what git version that actually is as it doesn’t match the versioning system for Git):

So this might just come down to an unsupported Git client version. You can see the path to git with which and then check that version directly with the fully-qualified path name (FQPN):

$ which git
$ /usr/local/bin/git version
git version 2.26.2

You can also look around for other versions of git installed:

$ find / -type f -iname "git"  2>/dev/null

I think I proved the Apple version hypothesis:

$ /usr/bin/git version
git version 2.24.1 (Apple Git-126)

Above is Git-126) (closing parenthesis and all) similar to the Git-128) on your system.

So, just changing the PATH environment variable to use the Homebrew version of git might resolve this:

If that doesn’t work, please let us know.

I can confirm that Apple Git-128 corresponds to git version 2.24.3.

I installed the Homebrew version of git using brew install git and now I have git version 2.28.0 (I didn’t need to change any environment variable).

netlify lm:info
  ✔ Checking Git version [2.28.0]
  ✔ Checking Git LFS version [2.11.0]
  ✔ Checking Git LFS filters
  ✔ Checking Netlify's Git Credentials version [0.1.9]

I’m afraid, however, that the problem persists even after this and following this once again just in case (this worked before enabling Netlify LM).

Thanks again for your time!