Builds since adding Netlify Gatsby plugin hanging on 'Post Processing'

I’ve updated our production build to use the Netlify Gatsby plugin as we needed to create some redirects programatically while creating pages. We’ve deployed this today but the two builds triggered so far have both stuck at ‘processing’ despite the following log messages:

12:26:01 PM: Skipping HTML post processing
12:26:01 PM: Post processing - header rules
12:27:12 PM: Finished processing build request in 12m46.109840305s

Can you confirm how we can resolve this (while still being able to create programattic redirects).

Is anyone able to follow up on this please? I have some back and forth with Netlify support yesterday but my builds have been stuck at processing since yesterday even though we’ve tried rolling the code back to before this started having issues. I’ve supplied the requested files to support first thing today but not heard anything further.


Hi Tim!

I think we’ve been working with you in the helpdesk, where we’ll be able to be much more responsive to you than we can here.

For those following along, Tim’s build (specifically, the netlify gatsby plugin) is generating a 16 Mbyte _headers file which our system is unable to process (not unique to his build - that is too large for our system), and we’ve worked with him in the helpdesk to guide him in remediating. Removing the plugin fixes the problem, so he’s now debugging what the plugin is doing and researching how to modify it, since we can’t provide direct tech support at that level on 3rd party code.