Build Error make: *** [ Release/] Error 1

I’m trying to deploy a website. but it keeps on failing. can you help me to deploy my site?

here’s the error
10:58:32 PM: make: *** [ Release/] Error 1

10:58:32 PM: make: Leaving directory ‘/opt/build/repo/node_modules/node-sass/build’

10:58:32 PM: gyp ERR! build error

10:58:32 PM: gyp ERR! stack Error: make failed with exit code: 2

10:58:32 PM: gyp ERR! stack at ChildProcess.onExit (/opt/build/repo/node_modules/node-gyp/lib/build.js:262:23)

10:58:32 PM: gyp ERR! stack at ChildProcess.emit (node:events:513:28)

10:58:32 PM: gyp ERR! stack at Process.ChildProcess._handle.onexit (node:internal/child_process:293:12)

10:58:32 PM: gyp ERR! System Linux 5.4.228-131.415.amzn2.x86_64

10:58:32 PM: gyp ERR! command “/opt/buildhome/.nvm/versions/node/v16.19.1/bin/node” “/opt/build/repo/node_modules/node-gyp/bin/node-gyp.js” “rebuild” “–verbose” “–libsass_ext=” “–libsass_cflags=” “–libsass_ldflags=” “–libsass_library=”

10:58:32 PM: gyp ERR! cwd /opt/build/repo/node_modules/node-sass

10:58:32 PM: gyp ERR! node -v v16.19.1

10:58:32 PM: gyp ERR! node-gyp -v v3.8.0

10:58:32 PM: gyp ERR! not ok

10:58:32 PM: Build failed with error code: 1

10:58:32 PM: Error during Yarn install

10:58:32 PM: Build was terminated: Build script returned non-zero exit code: 1

10:58:32 PM: Failing build: Failed to build site

10:58:33 PM: Finished processing build request in 2m29.395s

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile: Additionally, this Support Guide houses all of our resources for debugging build and deploy issues.

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

I’ve been searching for 3 days and all solutions that i see is not working :slight_smile:

Hi can you please check the following:

  1. Double-check your dependencies: Make sure that your project’s dependencies are up to date and are compatible with the version of Node.js
  2. Clear the Yarn cache: . Try clearing the cache by running yarn cache clean in your root directory.
  3. Rebuild the node-sass module manually by running npm rebuild node-sass or yarn add node-sass --force.

I tried this, but I always received an error :frowning:

What’s your site name?