Home
Support Forums

Vue.js build fail

Hi all,
deployment fails on error code:1
I have used Vue-cli-service to generate this project and currently using npm
local build is ok

Thanks for your help

here is part of my deploy log:

5:30:52 PM: 358 | NODE_MODULE(binding, RegisterModule);
5:30:52 PM: | ^~~~~~~~~~~
5:30:52 PM: make: *** [binding.target.mk:133: Release/obj.target/binding/src/binding.o] Error 1
5:30:52 PM: make: Leaving directory ‘/opt/build/repo/node_modules/node-sass/build’
5:30:52 PM: gyp ERR! build error
5:30:52 PM: gyp ERR! stack Error: make failed with exit code: 2
5:30:52 PM: gyp ERR! stack at ChildProcess.onExit (/opt/build/repo/node_modules/node-gyp/lib/build.js:262:23)
5:30:52 PM: gyp ERR! stack at ChildProcess.emit (node:events:394:28)
5:30:52 PM: gyp ERR! stack at Process.ChildProcess._handle.onexit (node:internal/child_process:290:12)
5:30:52 PM: gyp ERR! System Linux 4.19.167+
5:30:52 PM: gyp ERR! command “/opt/buildhome/.nvm/versions/node/v16.9.1/bin/node” “/opt/build/repo/node_modules/node-gyp/bin/node-gyp.js” “rebuild” “–verbose” “–libsass_ext=” “–libsass_cflags=” “–libsass_ldflags=” “–libsass_library=”
5:30:52 PM: gyp ERR! cwd /opt/build/repo/node_modules/node-sass
5:30:52 PM: gyp ERR! node -v v16.9.1
5:30:52 PM: gyp ERR! node-gyp -v v3.8.0
5:30:52 PM: gyp ERR! not ok
5:30:52 PM: Build failed with error code: 1
5:30:52 PM: Error during Yarn install
5:30:52 PM: Build was terminated: Build script returned non-zero exit code: 1
5:30:53 PM: Failing build: Failed to build site
5:30:53 PM: Finished processing build request in 3m44.94271953s

here is my package.json

{

“name”: “lrkmda-app”,

“version”: “0.1.0”,

“private”: true,

“scripts”: {

"serve": "vue-cli-service serve",

"build": "vue-cli-service build",

"lint": "vue-cli-service lint"

},

“dependencies”: {

"airtable": "^0.11.1",

"core-js": "^3.6.5",

"register-service-worker": "^1.7.1",

"vue": "^2.6.11",

"vue-router": "^3.2.0",

"vuetify": "^2.4.0",

"vuex": "^3.4.0"

},

“devDependencies”: {

"@vue/cli-plugin-babel": "~4.5.0",

"@vue/cli-plugin-eslint": "~4.5.0",

"@vue/cli-plugin-pwa": "~4.5.0",

"@vue/cli-plugin-router": "~4.5.0",

"@vue/cli-plugin-vuex": "~4.5.0",

"@vue/cli-service": "~4.5.0",

"@vue/eslint-config-prettier": "^6.0.0",

"axios": "^0.21.4",

"babel-eslint": "^10.1.0",

"eslint": "^6.7.2",

"eslint-plugin-prettier": "^3.3.1",

"eslint-plugin-vue": "^6.2.2",

"node-sass": "^4.12.0",

"prettier": "^2.4.1",

"sass": "~1.32.0",

"sass-loader": "^10.0.0",

"vue-cli-plugin-axios": "^0.0.4",

"vue-cli-plugin-vuetify": "^2.4.2",

"vue-template-compiler": "^2.6.11",

"vuetify-loader": "^1.7.0"

},

“eslintConfig”: {

"root": true,

"env": {

  "node": true

},

"extends": [

  "plugin:vue/essential",

  "eslint:recommended",

  "@vue/prettier"

],

"parserOptions": {

  "parser": "babel-eslint"

},

"rules": {}

},

“browserslist”: [

"> 1%",

"last 2 versions",

"not dead"

]

}

My netlify site name is : optimistic-elion-b7a21d

Hiya, sorry you are having trouble with your build.

This Support Guide contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

We also recommend trying to search the forums with the build error you encountered - it’s likely your question was already asked by someone else!

If you are still having problems, please provide as much information as you can on what you have already tried, what your build settings are, your package.json, etc. Thanks!

Finally got it working adding an environment variable in netlify deploys settings
NODE_VERSION=14.17.5

Thanks

1 Like

Thanks for letting us know you got it working and your solution! :partying_face:

1 Like