[Bug] Stuck on step 2/3 of site deployment

Hello, I just signed up for Netlify and while I was trying to deploy my first site using one of your templates, it turned out I got stuck on step 2 out of 3.

I discovered this is bug that occurs when you try to deploy from a mobile browser while having the GitHub mobile app installed. Since the GitHub app has link association to all of its own links, when I tap the GitHub button on step 2, Netlify tries to open the GitHub app but that doesn’t allow the user to continue to step 3. The solution that I used to continue to step 3 while on a mobile browser is to disable GitHub’s link association on Android app settings. That way I was able to advance to step 3 and finally deploy my first site on Netlify.

I hope this information is useful for other Netlify users and also to the dev team, so that they’re aware of this behavior on mobiles.

EDIT: The option to upload a folder project doesn’t work on mobile either. You need to fix this. Netlify’s mobile support is disappointing compared to other site like Heroku.

Hi, @rBok6. Thanks for the explanation about how you work around the GitHub app being made the default app for GitHub links.

There is an upload button on the mobile version of the manual deploy page.

For new sites, it is at the top of the page and looks like this:


For existing sites using the manual deploy process it is at the end of the page and looks like this:


Both buttons work for me when I test. If the button doesn’t work for you, would you please tell us what happens when you click it? Would you also please tell us what type of mobile device you are using, what OS version it has, the browser used, and its version as well.

1 Like

Hello @luke. Yes indeed that appears on the mobile version and it partially works because when I tap on “browse” it proceeds to open the file explorer but It won’t let me upload anything. Not even a single index.html file. There’s no pop-up or progress bar, nothing. It just stays there after selecting the file.

My phone is a Realme 7i with Android 10 and Realme UI v1.0

The browser is Kiwi Browser (chromium v101)

Hi @rBok6

We only support dragging/uploading of folders so dragging/uploading a single file isn’t going to work and isn’t a valid test.

Could you please try deploying via a folder on Chrome, Firefox, or Safari? Kiwi Browser is not something we’re going to try to support at this time. FWIW - We’ve also not tested our UI with your custom flavor or Android (Realme) so that may also be a factor here.

We’re also curious about your workflow and why you are trying to deploy via a mobile device. Are you developing your site on a mobile device? Just trying to deploy on mobile? We’d love some insight into what you’re doing.

1 Like

Hello @elden , thanks for your reply.

Indeed I have tried using chrome (v-104) to deploy my site but yet I still get the same behavior with it. Unfortunately I don’t have any other browsers installed, I might try using Firefox mobile just for testing purposes and give you my feedback.

If what you’re saying it’s true about only supporting folder uploads then that might be the problem, given that the upload button allows me to browse my file explorer but It won’t let me select folders, only single files. That would have to do more with android’s API then with my phone’s custom UI in my opinion.

And yes, I’m currently using my phone for development since my old PC got damaged a month ago. My mobile workspace consist of Acode editor, Spck Editor for Git client and Termux for Linux terminal emulator.

Hey @rBok6

I believe this is the case. Having tried Firefox, there is no option to select anything other than a file for uploading. A similar issue exists (or existed; I don’t have a device to test) with chrome OS too.

This is the same with iOS 15 too—only a file is selectable. I don’t believe this is a limitation on the upload functionality of Netlify, but rather a limitation of mobile OSes.

As you have a git client, I would suggest deploying sites from git instead. If you have the ability to install node etc. in the terminal (though I suspect not) you could use Netlify CLI.

1 Like

Hello @coelmay thanks for having run some tests yourself.

And yes, I have been deploying from git since my first time experience with Netlify. I just wanted to test how the manual process was on Netlify.

So in the case of impossibility to select folders on mobiles, it would be useful if Netlify implemented the option to select a .zip file and uncompress the file after uploaded. I know that one works on mobiles because I have used it on other hosting providers before.

This would be a feature suggestion now and not a bug I guess.

Thank you @coelmay for your contribution to this topic :+1:t2::100:

This is already possible @rBok6, both from a mobile device (just tested) and desktop. You need to ensure the site files are at the top level of the zip, not in a directory within the zip, for it to work.

1 Like

That’s good news @coelmay . May I ask which browser did you use on mobile?

I’ve tried uploading a zip file before didn’t get any response from the upload page after selecting the file. And I just tried it again but with files a the top level like you said and still nothing happens on the upload page. I used Kiwi browser and Chrome. Also if you could share a screenshot of the folder structure that you used inside de .zip file would be very much appreciated. Because I’ve been trying with only a few files inside the folder since it is a single page website and it’s less than 200kb in size.

I used Firefox (Beta) in a Pixel 4a 5G running Android 13.

As for zip structure, rather than selecting the directory the files are in, select the files in the directory, and zip the files. So if you had a directory called site like this

├── assets
│   └── styles.css
├── favicon.ico
└── index.html

you would select everything inside the site directory (e.g. cd site, then zip -r site.zip *.) So if you ran unzip -v site.zip you would see something like

$ unzip -v site.zip
Archive:  site.zip
 Length   Method    Size  Cmpr    Date    Time   CRC-32   Name
--------  ------  ------- ---- ---------- ----- --------  ----
       0  Stored        0   0% 2022-08-29 09:25 00000000  assets/
       0  Stored        0   0% 2022-08-29 09:25 00000000  favicon.ico
       0  Stored        0   0% 2022-08-29 09:25 00000000  index.html
       0  Stored        0   0% 2022-08-29 09:25 00000000  assets/styles.css
--------          -------  ---                            -------
       0                0   0%                            4 files

whereas if you zipped the site directory (e.g. zip -r site.zip site) you would see

$ unzip -v site.zip
Archive:  site.zip
 Length   Method    Size  Cmpr    Date    Time   CRC-32   Name
--------  ------  ------- ---- ---------- ----- --------  ----
       0  Stored        0   0% 2022-08-29 09:32 00000000  site/
       0  Stored        0   0% 2022-08-29 09:25 00000000  site/favicon.ico
       0  Stored        0   0% 2022-08-29 09:25 00000000  site/assets/
       0  Stored        0   0% 2022-08-29 09:25 00000000  site/assets/styles.css
       0  Stored        0   0% 2022-08-29 09:25 00000000  site/index.html
--------          -------  ---                            -------
       0                0   0%                            5 files

(Note: the files are empty, thus the size is 0.)

This would still deploy, but to /site rather than to /.

I haven’t used Kiwi, and I don’t use Chrome. The Android version (8, 10, 13, etc.) you are running, or the OEM specific UI (Samsung, Oppo, etc.) may change the behaviour I have observed.

1 Like

Hey @coelmay so I just tested Netlify on Firefox mobile and the upload .zip files works like a charm. I also tried uploading both folder structures that you mentioned and it seems it doesn’t make any difference. Netlify was able to select the correct index file for my website in both cases and displayed everything correctly.

It would be nice if other users could test the upload option on their mobiles with any chromium based browsers, since this whole issue seems like it’s cause by some incompatibility with such browsers.

I guess I’m gonna be using Firefox from now on. :blush: Thank you for all the support you’ve provided me. It was very useful. :v:t2:


Ah, this is excellent (I hadn’t tested, I had made an assumption.)

I don’t know a great many people use a mobile device for deployments. Any browser incompatibility is (quite likely) the browser, and not something Netlify can remedy.

A better way of living IMHO.

Hey there, @rBok6 :wave:

Glad you and @coelmay found a solution here. I would love to send your feature feedback to the Product team, but I just want to gather a few more details first. Can you describe exactly the feature you want available on mobile, and also why your workflow benefits from using your mobile device? This will help me capture the full scope of the request.



Hello @hillary , thanks for considering my feature request. But at this point I think this whole issue was caused by the mobile browser’s incompatibility to upload files (zip to be exact).

I had suggested to add the zip upload and extraction feature but Netlify had it all along, it just didn’t work for the mobile browser that I was using. So since Netlify has the feature already you may discard my suggestion. Just let the development team know about the incompatibility issues with chromium based browsers on mobile.

I know Netlify’s priority might not be mobiles but it’s an interesting topic to be considered given that coding on the go is a possibility and a lot of handhelds have a lot in common with PCs these days. The website Repl.it is a good example of coding on the go.

Anyway, I hope you have a nice day. Regards :pray:t2::wave:t2: