Browser Compatibility Issue with Carousel and Map

Hello, I’ve recently deployed one of my projects on my Netlify account. However, I’ve encountered an issue where the carousel and map at the bottom of the page work perfectly fine when viewed in one browser, but fail to function properly in others, such as Safari, as well as on my mobile device.

You can check out the site here: https://cafesite123.netlify.app/

I’m seeking assistance in identifying and resolving this problem. It seems to be a browser-specific or device-specific issue. I’d appreciate any suggestions on how to fix this issue.

Please note that this site has been created on Wordpress and then downloaded as HTML/CSS/JS file.

Thank you!

I’m seeing some errors in the console:

The issue doesn’t seem to be with Netlify or browser compatibity. It just seems to be incorrect JavaScript.

@andre9550 The issue, as shown by the first two errors in the screenshot provided by @hrishikesh, is that your owl.carousl.js and leaflet.js scripts are trying to load from http://localhost:10008

Depending on what you’re doing that may work for you locally, but it won’t work when deployed to Netlify.

You should fix where those scripts are hosted.