Bitbucket repository import issue

Process as usual. Click ‘Add new site’ > ‘Import an existing project’ > authorize Bitbucket… then choose a workspace and input repository name.

Unexpectedly, it now always returns an error with “Invalid filter query expression: Illegal character in input”. Pagination doesn’t work either. I just can’t access the repository I need. Tried multiple latest browsers (on Windows).

1 Like

We are facing the same problem.

Found related (same) issue in earlier post here: Import from Bitbucket not working

Hah… anyone!?

This only happens with Bitbucket. I tested all other import methods. Do I need to transfer repository for this to work?

We really hope that they will look asap into it. We have several environments waiting to be published for some clients and we cannot create any new site anymore through Bitbucket! We have exactly the same issue as @raimonds_wrong
Please Netlify, can you guys look into this issue asap?
Thanks in advance.

1 Like

It appears to be a URL params encoding issue. Failed requests contains q=name~%2522zalais%2522 and the part %2522 is incorrect. It should be q=name~%22zalais%22.

It’s weird that it only happens with Bitbucket.
Bitbucket API reference: Filter and Sort objects.

Please, Netlify… there is nothing we can do! :pray:


:wave: Hi folks,

Thanks for reaching out, and very sorry for the trouble!

We’ve opened an incident and you can follow along here: Netlify Status - Bitbucket repo import errors

We will keep you updated and get back to you as soon as we have more information.

1 Like

Hi folks,
We’ve moved this incident to Resolved. Please let us know if you are still experiencing any issues.

Great! Thanks for support. Now the case with searching the repository by name works.

I just want to mention… it’s not critical, but pagination still doesn’t work. It always shows the first page and clicking “Next” takes you to the top of the page without changing repository list.

Thanks again! :pray:

Hi @raimonds_wrong ,
Thank you for confirming you’re able to search Bitbucket repos now! :raised_hands:

The pagination issue is a known bug :bug: I don’t have a specific timeline on when it will be fixed, but it’s on our radar!

Yes, the search works again! Thank you so much :pray:
Have a nice day everyone!