Awaiting External DNS over 48h

Hi Support Forum,

My domain is not working for over a week now. On netlify it still says “Awaiting External DNS”. I configured the domain correctly in my external provider, I also checked the NS entries with dig (Dig (DNS lookup)) and they match the ones netlify wants. I am a bit lost at this point and would be grateful for your help. Thanks!

This message should only appear when using external DNS configuration.

As you’ve noted, is using Netlify DNS

$ dig NS	4502	IN	NS	4502	IN	NS	4502	IN	NS	4502	IN	NS

What DNS records exist for the domain in the domains section of the Netlify dashboard?

Thanks for your reply! These are the entries: 3600 IN NETLIFY 3600 IN NETLIFY

does that answer your question?

Thanks @Marlon.

Assuming there are no other A, AAAA, or CNAME records for either, everything appears correct so there is little more I can offer :frowning_face:

A Netlify support engineer can resolve this for you, however there is no guarantee of time frame.

Hello! Maybe I can help. After you add the domain try clicking the options tab (If you haven’t already.) and click configure Netlify DNS. Once you do this there is a setup wizard. Hope this helps!

Hey also another thing. If you want to point it at your site but Netlify’s nameservers aren’t working try creating an A record pointing at Netlify’s Load Distributing/DNS server (IP: If that doesn’t work then maybe try contacting your domain hosting company.

Here is part of the article: Article link: Configure external DNS for a custom domain | Netlify Docs Scroll to configure an apex domain
If your DNS provider does not support ALIAS, ANAME, or flattened CNAME records, use this fallback option.

  1. Find your DNS provider’s DNS record settings for your apex domain, such as
  2. Add an A record. Depending on your provider, leave the host field empty or enter @.
  3. Point the record to Netlify’s load balancer IP address: 75.2.60.

When I look at DIG it says no records of any kind can be found.

Based on the below quote @FoundationINCCorpora

I guess you wanted to post this link?

Yes, this may prove helpful if @Marlon wishes to use external DNS but there are reason you would use Netlify DNS instead of external DNS.

Yeah thanks that was what I was trying to do

Because he says the stuff isn’t working for him and the article says that if that stuff isn’t working then maybe try that. i am just giving that option because I know it works because it worked for me.

Indeed it does and will @FoundationINCCorpora

However I believe @luke or @Melvin could easily track and repair the missing/erroneous record(s) for the apex quicker and with less fuss than changing to external DNS.

First of all thanks for the answers @dig @FoundationINCCorpora

@FoundationINCCorpora I have searched everywhere for the option button, the only one I can find is under Domain mangement, Production domains. But this only takes me to the DNS panel, where I can find the DNS records.

Regarding your second idea, I would prefer to use Netlify DNS. This has worked for me before, I just don’t know why it doesn’t work this time and since I only plan to create additional dns records for a mailbox, I think it’s ok to stay with Netlify DNS.

@dig Thanks for the explanation about the external DNS. Should I write luke or melvin directly or will they respond to the post? How does it work here?

1 Like

Hi, @Marlon. I just fixed an with the DNS record for the apex domain ( not working. Everything does appear to be working correctly now.

Would you please let us know if you still see any issues?


Thank you so much @luke , that is amazing! Everything works now. :partying_face: