Auto-deployment not working after Github push

My site hosted on Netlify all of a sudden has stopped responding to any github changes, which are mainly PUSH and Pull Requests (PR).

I have tried the following solutions:

  1. Unlink and relink the repo
  2. Suspend the Netlify Github app
  3. Removed the netlify github app enitrely.

The only time it works is when I manually deploy my site. I am deploying from a github organization.

None of the repos on the company’s org that is connected to netlify is triggering an automatic build.
Again, it was working just fine, and now nothing works anymore.

Meanwhile, all events are coming up in the Git Audit on the Org’s settings.

I am really exhausted searching for solutions.


I am experiencing the same issue, and also exhausted.


Also experiencing as well, good to know it’s not just me! Was driving me crazy as I kept trying to disable and re-enable any setting that could have affected it.

1 Like

Hi, I see you all! My continuous integration is also in a hiatus haha. Let me raise this to the engineers.

Hang in there.

1 Like

Deploy hooks also seem to not be working

My website was working fine until now and it not being deployed automatically.
The latest commit it is showing on deployment page is not the latest on my github repo.

Here’s what it says on Netlify deployment page:********, published main@47ea20e. and 47ea20e is not my latest commit.

This is where you can see it is pretty old commit, not the latest one.

I have tried, unlinking repo and relinking it again. I have tried uninstall/unauthorizing Netlify from Github and reauthorized/reconfigure it.

Manually deploying the website doesn’t work either. Even tho it says Production: main@head, it is not the latest commit but that’s not the main issue. I want auto-deployment to work.

Thank you

I’m also experiencing this, but if I manually trigger a deploy, then it does work for me and uses the latest commit.

Everything seems to be working now.

1 Like

Please how were you able to fix this issue? Or was it manually triggering a deploy you were only able to use.

What site is this about @romulanxy?

@hrishikesh I just wanted to see how this would work for a mono repo?

Hey @rongxin , can you give a little bit more context to your question? Are you seeing this issue on a monorepo, or are you just inquiring about how auto-deployment might work for a monorepo? Let us know and we can work from there!

It stopped on one of my projects :frowning: not sure why. It’s so annoying!

Which site isn’t auto-deploying, @ZackPlauche?