Apex domain stuck on DNS propagation

Hi there

I think I’m having some DNS issues with my apex domain. It appears to be stuck on check DNS configuration. I know that it can take up to 48 hours but the www. change and removing my old A record happened instantaneously so I’m wondering if this is a problem at Netlify’s end?

I tried searching and I think it’s a similar issue to this thread perhaps?

But you had to manually intervene there.

Thank you in advance for any help.

Hi, @tristyb, you are correct. This is the same issue and it is now resolved. We do have an open issue tracking the root cause of this. It is rare but does still sometimes occur. We can manually correct it when it does and it is my hopes that the issue itself is resolved soon.

In the meantime, anyone experiencing this should let us know here in community and we’ll be happy to assist.

Thank you very much for the save @luke. I can already see it working :slight_smile:

1 Like

Hi @luke, i’m having the same issue here on my domain name. Can you check it out?
Domain -> hackph.tech

Thank you.

Hi, @Chi, and welcome to the Netlify community site.

I’m showing this domain is using external DNS. The www subdomain has the recommended CNAME record:

www.hackph.tech.	1800	IN	CNAME	hackphquarantine.netlify.com.

However, the apex/root domain doesn’t have the recommended A record (or ALIAS type record to the CNAME if your DNS service supports this). There is no answer for the apex/root domain at this time:

$ dig hackph.tech  +noall +answer

; <<>> DiG 9.10.6 <<>> hackph.tech +noall +answer
;; global options: +cmd

Here is a link to a GUI dig tool which shows this also:


The solution for this will be to either add an ALIAS record (again, only if the DNS service supports this) or the A record pointing to for the apex/root domain.

Would you please try adding that? If it doesn’t resolve the issue, please let us know.

Hi @luke thanks for the reply. Here’s a screenshot of my DNS.

Screen Shot 2020-03-25 at 11.23.40 AM

I tried doing the A record and it’s still the same so I went back to use ALIAS instead since it was recommended. (Nothing happens)

I have changed it to A record. Hope this work. I’ll wait for awhile.

@luke it’s working now. :slight_smile: I have reached out to my domain provider and instead of using the domain name as suggested in the documentation, they recommended to use the @ for the A record. Thanks :slight_smile: