Apex domain not redirecting from http to https

I’m using Netlify DNS and darylshaw.co.uk (apex) is set as my primary domain. The www subdomain redirects http > https primary domain no problem. But http://darylshaw.co.uk doesn’t redirect to https://darylshaw.co.uk. Same with branch subdomain (http doesn’t redirect to https) but I’m not sure if this is the expected behaviour here.

Shouldn’t be an issue with propagation as domain has been using Netlify DNS since 2020. Not sure how long this has been a problem for as site is low traffic. Only noticed when asking someone else to check the site out and they pointed out it was being served over http.

X-Nf-Request-Id: 01FXKP2VFQ9YQX0VWQZAAXNKKM

I’ve tried renewing the certificate and although looks to be a different issue, tried following the solution here but still seeing the same behaviour.

Netlify site name darylshaw.netlify.app

Hi, @darylshaw. I see the same thing and I cannot find the root cause. Everything is configured correctly but the automatic redirect is not happening.

I’ve filed an issue for this and our developers will take a closer look to find the root cause. We’ll post an update here when we know more.

The only thing that is unusual that I can see for this site is that split tests are enabled. Would you be willing to please test disabling the split test temporarily and then let us know if that fixes the issue or not?

1 Like

hey @luke! ahh good shout, I’ve stopped the test and that fixes the issue!

1 Like