429 Error on Deploy

Site name: dreamy-cascaron-738b02.netlify.app / uiuxdesignerjobs.com

I’m using Vue with Nuxt. Currently, my workflow consists of adding 2-3 pages/day to the website, then running “npx nuxi generate” to get a static folder, that I then drag and drop in Netlify. At the start of every month, I clean old pages to ensure I’m not deploying too many pages.

Today, I followed the same process. However, when I drag-and-dropped the output folder into the “deploys” tab, I keep getting an error that simply states “429”.

I’ve read other topics about this, but they don’t seem to have exactly the same issue, as other commenters seem to be deploying via Github. I tried removing a couple of pages before deploying, but that didn’t seem to help. i use chrome, i tried using firefox but that didn’t work either.

Update: tried deploying through a different network; that didn’t help either :confused:

Any help is appreciated, thanks!

@joseph1 You may have already encountered this answer when reading other threads, but “Drag & Drop” isn’t a very robust upload method and is known to fail for various reasons that can’t/won’t be fixed.

If you can, you should try and use the Netlify CLI.

Specifically you should read the documentation for Manual Deploys.