Drag and Drop deploy fails with error 429

I don’t have any logs, just after drag & dropping the new version of the site, the drop zone shows “429” and the deploy process hangs.

I tried an old version of the site, and deploy worked (a version that was actually already deployed before).

The only difference I see between the two archives is that the old one is 30,2MB and the new one 35,2MB

Is the archive too large ? I don’t think so, I remember deploying larger archives before.

How can I fix this ?


Hi @SimonWMX,

Thanks for reaching out!

We have a Support Guide on troubleshooting Drag and Drop deploys here:

We recommend deploys under 50MB and with no file being over 10MB. If you have files larger, we recommend Netlify’s CLI.

If you could give the guide a read and see if you meet any of the conditions.

I too have been experiencing intermittent 429 errors on manual deploy. I was able to get the same package to upload 1 time this am (CST) but fail all other times. My deploy bundle is 1.6mb. Looks like this might be an issue within Netlify? Have uploaded hundreds of packages over the last couple years and this is the first time seeing 429 on manual drag and drop deploy. Thank you!

We’re having the same problem - deploying a simple static HTML site, no build actions beyond deployment of the uploaded files. Total size 4.49MB, but we’re getting 429 every time at the moment. Tried in a different browser to eliminate any cookie/cache issues.

same issue here, on a ~15mb website

Hey guys,

Tried again this morning, and this time the deployment worked like a charm ! It was actually very fast.

Also working for us this morning.

glad to hear it y’all!