404 when connecting to name.com domain

Hey everyone,

I am trying to connect a custom domain to a website hosted on the free Netlify server. I simply pointed to the servers IP address and created an A and CNAME record on name.com and it seemed to work for a while, but a few hours later it resulted in only showing the 404 page.
I also tried by adding an ANAME but the result was the same.

I am very inexperienced when it comes to hosting websites. Maybe you have some advice on what I might be doing wrong.

I really appreciate your help.
Thank you.


Hi, @DanApro, the custom domain must be added to the site settings at: Site Name > Settings > Domain management > Custom domains. Was that done?

If so, what is the custom domain which isn’t working?

I’m fairly certain I know which custom domain this is for. If I’m correct the issue is that the www subdomain points to Netlify but the apex/bare/root domain is primary. The apex/bare/root domain isn’t hosted on Netlify.

So, the www request comes to us and then we redirect to the apex domain. The apex domain isn’t hosted at Netlify and that results in the 404.

If there are other questions, please confirm the custom domain which isn’t working and we’ll be happy to assist.

Hey Luke,

thank you for the response, I really appreciate it. The primary custom domain has been set up and the www subdomain points to Netlify just as you wrote. I am also not getting any of those yellow triangular warning signs in the custom domain settings.

The custom domain is aromadesign.at and it was created in 2013. It has an A record with an *, so I assume that this might be the apex domain, and a normal A record that points to some other IP, but I’m a bit concerned about deleting that one. The third A record is the one pointing to Netlify.
So we’re having three A records, a CNAME that points to the default Netlify domain romantic-hamilton-cba74a.netlify.app and an MX that connects to some email server.

What do you think I should remove? Also should I add an ANAME record? As I mentioned, I have tried that before but the result was the same.

Thank you so much!

Hi, @DanApro. For the apex domain, I see it set as primary here:


I recommend making the www subdomain primary and there is more about why here.

I do see an A record pointing outside of Netlify here:

aromadesign.at.		283	IN	A
aromadesign.at.		283	IN	A

The A record for points to our service. The A record at will prevent Netlify from issuing an SSL certificate for the apex domain.

I do recommend deleting that record if you want to use the apex domain at Netlify. However, it is up to you to know if it is safe to do so or not. I have no idea why the record exist or if it is required or not.

If you want to use only the www subdomain for the site that is also possible but it is a setting which our support team must change manually currently. If you want this site to be www only or if there are other questions, please reply here anytime.

Hey Luke, thank you again for the help. I deleted the A record at as you suggested.
I’ve noticed that I’m not getting any 404 after I add or remove some type of a record, but I have security issues and I’m only able to visit the site when I enable advanced settings in the browser. After a few hours the page will jump back to 404. So there’s an SSL issue and this. What can I do to solve this?

I’ve hosted one website on your server before and I set up DNS settings the exact same way.
CNAME set up as the default Netlify domain and A record pointing to your server.

I’ve read the blog post that you’ve linked, however I’m still a bit confused if the apex/root domain is the primary domain?
Dumb question: can I simply fix it by adding www. to aromadesign.at?

Excuse me if I have misunderstood you in some way.

Thank you for your support!

Hi, @DanApro. The SSL certificate only covered www.aromadesign.at and not the apex/bare/root domain (aromadesign.at).

I updated the SSL certificate with the “Renew certificate” button on the page in the screenshot above.

Are you still seeing issues with that site?

Also, I still see aromadesign.at is set as the primary domain. While this will work it means the site doesn’t use our full CDN.

Again, I strongly recommend making www.aromadesign.at the primary domain using the “Options” button shown in the screenshot above. Doing that will allow the site to use our full CDN.

As always, additional questions and comments are welcome. Please reply here again if there is anything unclear or if you still see any issues.

Thank you Luke, at least it works now. I’ll update it to www. Really appreciate all the help!

1 Like