Visiting my custom domain works great, but clicking a link redirects to my Netlify custom domain

Hey all,
I just finished setting up my website with Google Domains, Publii, and Netlify. I can visit all the pages of my site, but when doing so it shows my Netlify subdomain in the address bar. I want it to show my custom domain and not Netlify’s subdomain, but I can’t find anything that talks about that. Is that done through the _redirects file? If so, does that go in my Publii site’s “input” folder?

My Netlify instance name is
My custom domain is

Hi @ianbogue! Welcome to netlify community.

I saw one issue with your current setup. Your SSL certificate was only covering your bare domain and not your www. I fixed that.

While I was at it, I noticed your DNS for your www could use a change:

$ host is an alias for has address

You’ll want to change this DNS to take advantage of our CDN by following the instructions in this post: [Common Issue] Can I host my site on Netlify but keep my DNS at my domain registrar?

However, I don’t think either of these is causing the issue. Are you saying that when you visit that it shows in the address bar?

1 Like

Thanks for fixing my SSL, @laura! That is exactly my problem, but I just figured it out. In Publii, there is a setting to use relative URLs. I enabled that and synced my site to Netlify and the links are no longer pointing to*. It does mention that share buttons and “Open Graph tags” won’t work properly, but as I have no idea what the latter is, that doesn’t matter to me.

Thank you again for fixing the SSL error, that also confused me. I changed the DNS setting you mentioned, so that should update in a few minutes. I tried using host, which returned Host not found: 2(SERVFAIL). Did I mess something up?

EDIT: The host command successfully shows the information.

Hi, @ianbogue, it looks like the DNS records are correct when I test now. Are you still experiencing issues? If so, would you please tell us more about what isn’t working.

Hi @Luke. I am good to go! Everything is working the way I expect it to, so we are done here!