UI bug on Netlify Analytics dashboard - page becomes black


I am experiencing a very weird bug since I started using Netlify Analytics.

Sometimes when I am browsing the Netlify Analytics tab in Netlify admin dashboard the whole page becomes entirely black.

I inspected the page and what happens is that the <div id="root" tabindex="-1"></div> becomes empty. Somehow the application DOM stops being added in there.

It does not happen all the time. When it happens, it happens after I started scrolling, usually halfway down the page, when I getting to the Top sources section (the one that I like to see the most, which makes the bug extra annoying). I have the impression that it happens more when I change the time period from 30 days to 7 days or 24 hours.

The only way to recover from it is by reloading the page. Sometimes it happens multiple times in sequence.

It is not a huge issue, but it is VERY annoying. Please fix it.

hi @rodrigohgpontes, thank you very much for bringing this to our attention. We’ve filed a bug report and will look into it, and i’ll let you know when we have fixed it.

As a workaround, for now, have you tried using a different browser, or does this always happen?

I just tried a few times in Firefox now (before I was using Chrome, both on Fedora), and it happened just the same.

thanks for that @rodrigohgpontes - I have made note of it! We will update here once we think it is fixed.

Could you let me know the version of firefox you use, @rodrigohgpontes? I can reproduce easily with chrome, but not with the last non-alpha/beta release of firefox.

I am using 72.0.2 (64-bit) - Mozilla Firefox for Fedora - 1.0

I’m not sure how soon we’ll get this bug fixed, but as I mentioned, it doesn’t occur in the current release version of firefox in my tests. Could you try an upgrade and see if it helps you?

I won’t change browsers over this bug, I’ll just live with it.

No need to switch to Chrome! The suggestion was just to update Firefox to the latest version. Totally understand if that won’t work for you though. Let us know if we can help with anything else at this point.

Sorry, you got it backwards. My current default browser is Chrome, I only tested on Firefox because I was asked to.

Yup, makes sense. While I can’t promise that we will fix it or any timeline, I CAN promise that we will absolutely follow up in this thread if we get a fix in place for this.

hi @rodrigohgpontes - good news. We were able to isolate the cause of this issue and have rolled out a fix! You should now no longer see the black screen while accessing the analytics dashboard. If you do, please let us know right away! thank you again for reporting this and helping make Netlify even better.

Just an update, it is not fixed. It never was, actually it is happening even more these days. About 90% of the times that I change to “7 days” and scroll.

thank you for letting us know! we have re-opened the issue and going to dig into this one more time and hopefully fix it for good this time.

hi there, @rodrigohgpontes and friends - took a bit longer than we had hoped to really get to the bottom of this, but we feel confident we have fixed it for good this time and just rolled out some new code :tada:

if you do see it please let us know as soon as possible - and if you can include a screenshot with any console errors you see when this occurs that would be super helpful so our Frontend Engineers have the right info to understand why this is being so difficult! Thanks for your patience everyone.

Hi Perry, it is definitely better, but not fixed yet.

Before this last change, it was happening like 80% of the time. Usually when I changed the time period, but sometimes even when still on the default 30-day time period.

After your message, I went to test it and I was hopeful for a moment, but still happened (2 times in ~30 times I tested refreshing the page).

Here are some screenshots of the UI, the HTML elements, and the browser console.
But the key info seems to be this error:
app.bundle.js:90 TypeError: Cannot read property 'start' of undefined at Object.descriptionFormatter (app.bundle.js:253)

oh man, how frustrating (for you and for us). We are taking another look. We will get this figured out! Thank you for your patience :pray: