Trouble adding "A" record type

I’m having trouble understanding a few things about the netlify DNS after looking through the docs.
I don’t understand what are the “NETLIFY” records. They have a URL value of a Netlify project that does not exist anymore. I’m struggling to find a way to remove them which relates to my next problem.

When I try to add an “A” record with a value of an IP of a Bluehost Wordpress site, I am getting an error (example .com instead of actual domain, extra space since I can’t post to many links):
dns_api example .com - example .com/A: 400 - link exists, all config must be empty

Image of my DNS config. I blacked out the name of the actual domain, leaving the names of the subdomains.

I couldn’t find any information in the Docs about this issue.

I believe this may have to do with the existing “NETLIFY” record for the www.example .com domain I want to reassign.

EDIT: I am now getting an “Access Denied” for any record I try to add. I even experimented adding a TXT record and I still get the “Access Denied” error.

Any help would be appreciated, I have absolutely no idea what to try next :cry:

Hey Jeff,

Couple of things going on here:

  1. if there is a conflict for a domain name, you adding something would be unlikely to work as described. You’d then have two answers that would be used in equal preference so your site would show half and half to visitors - old and new address. Perhaps you need our help in removing some existing records? (All NETLIFY type records are non-editable/removable by you since doing so would break your website hosting with us).

  2. the “Access Denied” is likely due to a bug on our side that we have to fix in the database. We need to know the domain so we can get it fixed up. It could also happen due to your permissions around the domain, but impossible to tell without the domain name, so hopefully you can tell us?

Yeah, there wasn’t a need to censor the domain. The blacked out bit is “vecgraph”. The domain is

But if you need account login information, it might be better to send you that privately. :sweat_smile:

We will never ask for login information (well, email address or github slug maybe but NOT password!) and it would of course be fine to DM even that.

I fixed up that zone so that it should not show permission denied anymore. Could you confirm that that works better now? Did you want some NETLIFY DNS records removed too?

Thank you @fool.
I just tested adding a TXT record, so I can confirm the permission denied error is solved. :+1:

I think the NETLIFY records (Inside the black box) need to be removed to free up the domain and get rid of the error that happens when trying to add an “A” record:
dns_api - 400 - link exists, all config must be empty

The value those records have: is a project that does not exist anymore.

tis true, you can’t affect those records. Would you like to provide us with new values to put in place to prevent downtime between when we get those removed and when you’d hear that we’d removed them and get around to putting them in place?

Just removing the NETILFY records is fine, those projects don’t exist anymore.

Note: We are trying to change the top level domain (www. vecgraph. com) to point to an IP adress using an “A” record. Currently vecgraph .com is pointing to this NETLIFY project:, not vecgraph-explore.netlify. com which is in the DNS config. Somehow it still works magically :man_shrugging:

I can’t see any NETLIFY records for project in the DNS config. So, if I disconnect vecgraph-landing from the custom domain, will I be able to add an “A” record?

Hi @jeff_basanta, it works because we don’t route requests based on the specific netlify site the record is pointing to. We check which site has that specific domain on it as a custom domain or domain alias and use that to route the requests.

Once we remove the NETLIFY records, the domain will stop loading your netlify site. If you want to point that domain to a non-netlify site then you can create the appropriate DNS records now so once we remove the NETLIFY records, clients will connect to the servers you add the records for.

1 Like