Transform images not working, create-react-app

Yeah, it’s weird. I’ve uploaded that image now to: /photos/orange.jpg and it also seems to be of type “octet-stream” when I test in the inspector…

So you know I tend to use Git Tower to manage git stuff, I’m not super comfortable in Terminal, but I don’t see why pushing though that should make much of a difference…

Sending you the git config in PM

edit: I’m exporting the images from raw files in Lightroom if that’s of any help, but it seems that given the orange file seems to be doing the same thing that’s probably not the issue.

It seems like your config does not contain the lfs.contenttype=true flag.
Wondering why that is.

Could you do this again and check if the flag shows up in your git config?

git config lfs.contenttype true

Note: This command only applies it to your current repository.
To have it globally try:

git config --global lfs.contenttype true

Hmm, that’s weird — when I check the config file in .git in my project folder it has the following lines at the end:

[credential ""]
	helper = netlify
	contenttype = true

(I include the credential part because as I previously mentioned I’m not sure this should be there — I added it out of desperation earlier :sweat_smile: - should I just remove it?).

Changed the global content type as you suggested and will try a new upload…

I changed the global content type and I still get “octet-stream” when checking the latest image – dscf7558.jpg.

Hi Will,

our logs show that uploads for your site happen with 2 different git-lfs versions.
One of them is at 2.3.4 which is too old to work with Large Media.

It was used three times this afternoon (CET).

Can you please check the version again?

git lfs version

That’s so weird, when I run that command from the project folder (or anywhere), I get this:

git lfs version
git-lfs/2.8.0 (GitHub; darwin amd64; go 1.12.7)

@willhindson, I think it is possible that the GUI Git client (Git Tower) doesn’t use your local CLI version of Git and, instead, that it has this older version of git-lfs hard coded into it.

Are you using the most recent release of Git Tower? If not, it might be possible to resolve this by upgrading to a newer version of that software.

If upgrading doesn’t fix the issue, the workaround will be to make sure all initial pushes of any Git LFS media is first done in the CLI as this is using a git-lfs version which is new enough to be compatible and will set the content type correctly.

If you want to test a new version of Git Tower, please send me a PM/DM stating the day/time/timezone when you tested (it doesn’t have to be exact) and I’ll let you know what version git-lfs it reported when it connected.

@luke :astonished: I feel so dumb, that’s it. I just tried staging and pushing through the CLI in my project folder and it worked. Content type jpeg.

Sorry for having wasted your time with all the rest of it. Lesson learned: I wasn’t using the latest version of Tower and there must be some baked in older git LFS version. Also, I should probably just get more comfortable with git commands in terminal.

@marcus I would massively appreciate if you’re able to run a script to fix the content type of the already uploaded images but let me know if that’s too much hassle and I can start over.

Thanks again for all your help!

Going to fix those that are already in your account (in the UI under large media) today.

Thank you! Hopefully others can learn something from the thread – aside from the git confusion, it was really useful to learn about the content type settings. :smiley:

Except I shouldn’t have brought up that flag, because it defaults to true and people should never turn it off

Ah, yeah. I realise I’m probably in the minority using a git GUI like Tower, but it might be useful to mention somewhere in the docs that there might be different git LFS versions depending on whether you’re using the terminal or an app like Tower (unless I missed it!).

1 Like

@willhindson all your files should be fixed. Please tell me if you still have trouble with any.
(I noticed that one of the drawing you uploaded as .png is actually of image/jpeg)

Thank you so much, again! The drawings were mostly a test so I will check through those, I really appreciate the photo fixes. Will let you know if there are any other issues but should be good for now :crossed_fingers:

@marcus @luke I thought you might like to know the site has finally gone live! Thanks so much for your help earlier :slight_smile:

1 Like

that’s great! I really like the site. Proud to host it :heart_eyes:

1 Like