Tailwind Styles are not being displayed on Netlify

Hello everyone. I’ve a React App with Tailwind and other libraries. The problem is that when I deploy my build folder generated with yarn build styles are not loading properly, but if y run a yarn start inside that build folder on my local computer, everything looks fine.

The same happens when I deploy the app through GitLab.

This is my site: https://festive-booth-3f3a79.netlify.app/
And you can take a look at all the code here: Lucas Di Stasi / react-tmdb · GitLab

Thanks in advance.

Did you try changing purge to this: ["./src/pages/**/*.tsx", "./src/components/**/*.tsx"]?

1 Like

Changing to this: content: ["./src/pages//*.{js,jsx,ts,tsx}", "./src/components//*.{js,jsx,ts,tsx}"]

Makes everything work now. You was close to the solution :slight_smile:


That makes sense, I just downloaded your repo and your files are jsx, not sure why you had set tsx extension in the config before.

@hrishikesh I’m having this problem and I’ve tried every permutation and combination. Please tell me what can be done?
the-spot-backup/tailwind.config.js at main · zubin-madon/the-spot-backup (github.com)

Hey @zubin,

Your repo appears to be private.

Issue solved. thanks.

1 Like