SSL Issues - "This site can't provide a secure connection"

Hi all,

WOuld be really grateful for any advice anyone can offer on this issue. I’ve set up a website for a friend and hosted it on Netlify at I’ve also registered and set up the DNS records to forward to my Netlify app. However, I get intermittent issues with the page not loading and giving the error message “This site can’t provide a secure connection - sent an invalid response - ERR_SSL_PROTOCOL_ERROR”.

I’ve set up a DNS A record with HOSTNAME @, value, and a CNAME record HOST NAME www, value I’ve also set up both domains and on Netlify.

I initially tried to use a Let’s Encrypt certificate, but it seemed to just load for a while and then never work/install the certificate, so I instead installed the custom certificate I got from my domain name registrar This initially seemed to work, and indeed still does work a lot of the time - it shows a secure connection when I visit it on a browser on my laptop, and reviewing the icon in the address bar shows that the SSL certificate is valid.

I’ve been unable to identify a pattern in who can’t access it or when, it seems to happen slightly more often on mobile browsers or on mobile networks, but it’s not always any one browser or connection as far as I can see. It will sometimes work on my mobile browser and sometimes not.

I’ve tried all the troubleshooting posts that I can find on these forums, and used, and everything appears to be set up correctly.

However there is also an AAAA record which will cause an issue as it isn’t served by Netlify

$ dig AAAA	4437	IN	AAAA	2001:8d8:100f:f000::200

Remove this record.

1 Like

Thanks for your reply - I’d since changed the default domain to instead of, and this seemed to stop the problem from the limited testing I was able to do. I’ve also now deleted the AAAA record so I’ll post a reply update if the problem reoccurs, but for now it seems to be ok.

sounds good! glad to hear it!