SSL certificate not being issued

Hi, I’m working on a website, for a while it had a test domain assigned to it, we had no issues with the SSL certificate then. We now need to move it to the official domain, but when we did, the certificate was not renewing and it displayed an error. I tried to mount the project on a fresh instance and add the domain there, I don’t get the error message, but the certificate isn’t working. It prompts me to verify the DNS settings, it says it works but nothing happens.

the netlify site name is and the final domain is

I read a couple of threads on this, the only thing I’m sure is that the DNS records a set correctly and that allegedly there are no AAAA records (I have no access to these settings, my client uses Hostinger and their IT guy manages it, so I can’t know for sure).

I see a valid certificate on

It was an AAAA issue, Hostinger has it on their system but you can’t modify it yourself. Spoke with them through customer supper and the issue was solved. Thank you for checking though.