SPF Record issue in the DNS settings

PLEASE help us help you by writing a good post!

I own xn--tatilgnleri-yhb.com and I am trying to set up MX records into the DNS settings. I am having issue with the SPF record. I have tried to enter it both with and without quotes but every time I get the following record: v=spf1 include:spf.migadu.com -all

dns_api xn--tatilgnleri-yhb.com - xn--tatilgnleri-yhb.com/TXT: 400 - "[v=spf1 include:spf.migadu.com -all]" is invalid for "TXT" record type

Hi, @darkhorn. This one has me stumped. I’ve testing making the same record on a different domain and it worked. I even did a copy/paste of your text in case there was some unicode character being used (DNS is limited to ASCII currently). However, the next above contains no such unicode characters.

Would you be willing to please make a HAR recording of this issue occurring?

If you do make the recording, please do NOT post that recording here. It will contain access tokens for your account. You can, however, private message that to one of our support team. I’ve confirmed that PMs are enabled for your forum login.

I thought that it might be because of Firefox but Google Chrome returns same error. I have send you the HAR.

I guess the problem is with TTL. I was omitting the TTL. Now I have entered it as 300 and it worked. Or may be you have updated the back-end.

Now I have same issue with DMARC record.

Do you mind sharing the HAR file with me as well? Or we can wait for Luke to take a look at this.

Hello hrishikesh, just I have send you the HAR file.

For some reason, I can see that the data being sent from your payload is getting encoded:


I tried to add the same record on my end (on a domain in my account), and it shows like this:


Interestingly though, using decodeURIComponent('v=DMARC1;\u00a0p=quarantine;'), does return v=DMARC1; p=quarantine;, but I think that encoding is causing issues.

Are there some browser extensions or something that is intercepting with your network? Could you try a different device?

@ hrishikesh, that \u00a0 might be the problem. Few hours ago I have tried to enter DMARC without removing or disabling any extension from my Firefox and it worked without problem. However this time it didn’t had \u00a0 but it had normal space.

Also, the problem existed on my Google Chrome too. Both Firefox and Google Chrome have only one common extension, The Camelizer. But it looks like it has been updated on March this year.

Currently I have no problems left. Thank you.

Hi, @darkhorn. Thank you for the additional details and for sharing what you believe the root cause was. I’m sure this information will help others in the future.