Site won't open without WWW // Managing DNS through Netlify

Hey there –

Can I get some help making my site work without the “www” in front of the address?

I recently purchased my domain through, deployed using Netlify, and delegated my dns management from Hover to Netlify by adding all four Netlify name servers on It seems to be working because when I tried to make a dns settings change at, they gave the following message:

This domain is using third-party nameservers. DNS records added here won’t have an effect.

My site loads when I go to “”. But it doesn’t load when I drop the “www”. If I go to the www version just one time on a browser, I’m able to drop the www going forward for that specific browser.

In the Netlify DNS Settings, I’m only showing two DNS records: one with the name and another with Both point to the “value”.


Thank you!


You can set your apex domain as your primary domain by going here: and then clicking the ‘set as primary domain’ as shown in the image:

Thanks Dennis. That worked.