Site functions have become slowed, time out, and site MISSING from both Team and sites list?

Netlify internal site name/url is: competent-goldberg-a5177a.netlify.app.

  • Build and so forth have been fine; not re-built in several months

  • today for first time ever, the functions on this site are very slow - and time out. This may or may not be your problem, but looks like it. Be advised that if you just address the site, you get a simple string reply, and that is fast.- 115ms. It’s the complex functions which time out as never-before-seen slow. Yours and the underlying FaunaDb status sites show you both functional, for what that’s worth.

  • BUT: before I can do anything to tie this down, I can’t actually find the site on Netlify suddenly. I am wondering if this may be tied up with your announced changes in Dashboard?
    Here are the important details:

  • site is named as mentioned above, but it doesn’t show up on any of the three Netlify logins we have:for the project: narrationsd, jose.urra86, or combatcovideq, all @gmail.com.

  • I believe it should be at combatcovideq@gmail.com’s team. But it doesn’t show on the Team overview there, or for any of the three teams, or using https://app.netlify.com/sites/competent-goldberg/deploys to find it by your listing url.

  • In fact several of the team lists look short, possibly.

  • But please help by letting me know which team the site is actually under (once again should be combatcovideq), and also make it appear, so I can work on it, discover by Function logs just what is causing the suddenly new timeouts – Thank You!

(underlying is question whether you’ve slowed us down unannounced due to low usage (but important usage - look at what the site is). Finder there through Algolia is super-fast, Viewer through Netlify-Fauna backend is now super-slow/timeout mostly, while had been quite fast…I can come back on this after we recover ability to see thus work with the site…again thanks.)

All right, site performance is back to normal. The runtimes range from 1.5 to 345ms, which will hope is down to uncached Fauna accesses when they come. There’s an occasional 172ms Init Duration. So we are very far within limits – memory to say it also is circa 75MB.

  • how did I find the executable? Indeed, you changed your interface. Would it have been a problem to have the word ‘More…’ displayed, instead of a microscopic tick that looks like some kind of format mistake?

  • There was a serious delay problem in our short Functions this morning, when reported, and only a 5 second (not 10) interval before your server returned what Axios reported as a cancel. There is no indication of any problem on your status site, nor on Fauna’s today – and Fauna would not cause a timeout unless it had a delay of its own to the 10 second point, so I suspect you will own this one.

Very disappointing for future intentions, that this happened and in this blind, hidden from reporting way.

In all other ways, we have been very pleased with Netlify, once accumulating the scattered information for the app itself to succeed.

So, we survive. One more thing that would be easy for you and helpful, would be if your app listing reported always both the primary url, and the Netlify app name. Otherwise one must dive down into each site’s link to discover whether it is the app name sought. Thanks for your attention on this.

I don’t know what kind of turnaround you expect on this support site – which had also ‘forgotten’ a LastPass-recorded previous login, so that I had create a fresh one, but half a day later nothing.

Fortunately the site had recovered as mysteriously as it had gone bad, and by dicing with your interface, we could actually find the app in question. By that time, the Function log of the trouble period had of course disappeared…

hi there, thanks for sharing this - there are a number of issues here, so I’m going to get some additional eyes on this to evaluate these circumstances. We definitely want you to have a better experience than the one you are having!

thumbs up for that, Perry, thanks

In the future when you see a problem with a function invocation, could you please gather the x-nf-request-id HTTP response header for a problematic load, as described in this doc? [Support Guide] Netlify Support asked for the 'x-nf-request-id' header? What is it and how do I find it? - this is the debugging information that is most helpful to us to understand misbehavior such as you describe. Without it it is pretty hard to directly address reports like these; with it the possibilities are much higher that we can understand a root cause.

We do not promise any specific response time here. If you are a customer using a Pro plan or higher, you can contact our helpdesk for quicker responses, but below that, we provide the support we can on the timeline we can. If you need a guaranteed response time, that is available with a Support contract, described here: https://www.netlify.com/pricing/#support . I am not suggesting that you will find a guaranteed response time to be worth those prices, but that is what we charge for that behavior. Feedback on the pricing will get passed on to our product and sales team, so don’t hesitate to let me know if you have it, but also, don’t expect any sudden changes there.

Thanks also for all this user experience feedback! I’ll review it with our UX team in our next meeting. I could in particular use a screenshot of what you’re talking about in this comment:

Would it have been a problem to have the word ‘More…’ displayed, instead of a microscopic tick that looks like some kind of format mistake?