Site build has started timing out with no changes

Overnight, our site has stopped building due to a timeout. I’ve tried re-deploying successful builds from yesterday, and they are also timing out before the site can build (build time is usually about 1 minute). Using Jekyll. Has anyone run into this before. Thanks for your help!

6:07:50 AM: Jekyll Feed: Generating feed for posts
6:36:04 AM: Build exceeded maximum allowed runtime

hi there, have you read through these posts?

and relatedly

sounds to me like your build is indeed timing out - why, i can’t say without knowing things like your instance (netlify) name. But it seems likely that something to do with jekyll isn’t completing, so the build times out.

Give us a shout if neither of those posts help you identify the culprit. Mention what you’ve tried, and what your netlify name is.

I have yes, thanks. Adding “&& ps auxw ; false” doesn’t seem to give any additional information and the blog with further debug steps doesn’t exist anymore.

2:03:40 PM: Executing user command: jekyll build && ps auxw ; false
(Doesn’t do anything)

What’s strange about this is that previous commits that have worked just fine in the past are now failing, which is the major other thing I’ve also tried – rewinding to known good code. I’ve also tried deploying other branches; all fail. I’ve tried pre-building the site locally, that seems to work fine.

Not sure how to get my Netlify name but I believe it may be “Justin Dunham”?

Thanks for your help!

Hi Justin, can you please share a URL to one of these failing deploys so that we can take a look?

Hey Gerald – sure, like this?:

That’s exactly what we were hoping for, Justin!

no real smoking guns there - it seems like the feed generation is just taking forever :frowning: Does it scrape data from other sources, and maybe there is more data there or a network timeout? I guess when you build locally it doesn’t take 30 minutes (or many minutes) for that part?

Could you try in our build container? - That way you could at least attach to the running build if it takes forever and see “what is happening”.

You might also try running jekyll in verbose mode even in our CI to see if it will “be more talkative” about what is happening during that step so you can see if it hangs on some particular spot… That’s a bit less effort than installing docker if you want to try it first :wink:

Thank you – that suggestion to run Jekyll in verbose mode is really helpful, helped me zero in on the file that was causing the problem. That should be in your docs, maybe it is and I missed it. Again, really appreciate that.

Here was the culprit, a blog post containing the following. Removing the “created_at” line fixes the build on Netlify.

(To answer your question, I’ve never had a problem on my local machine or even on Netlify until I posted this question, and nothing has changed in this file in about two years. Usually takes about a minute to build. And attempting to re-deploy previously successful builds failed as well.)

{% highlight json linenos %}
{"created_at":"Thu Dec 01 09:54:56 +0000 2016","id":804262498022981632,"id_str":"804262498022981632","text":"\u4e09\u6bdb\u3060\u304b\u3089\u3001\u3063\u3066\u3053\u3068\u3082\u306a\u3044\u3051\u308c\u3069\u3001\n\u30aa\u30c3\u30c9\u30a2\u30a4\u306e\u3088\u3046\u306b\u898b\u3048\u308b\u3093\u3060\u3088\u306a\u3041\u3001\n\n\u3053\u306e\u30b3 https:\/\/\/yfl9SpTVCS",...,*"lang":"ja"*,...}
{% endhighlight %}

Successful deploy: