Rubygems version outdated; cannot deploy

My site runs ok locally on MacOs Ventura 13.1. I have run bundle update locally.

  • we need to know your netlify site name.

sonomamatsuri

  • Build problems? Link or paste the FULL build log & build settings screenshot

2:31:49 PM: build-image version: a2d22d22e4555d1ef0a972ed14a0a4b366ad20c4 (focal)
2:31:49 PM: build-image tag: v4.16.3
2:31:49 PM: buildbot version: 211709fe0bb687fe4fe2ebbb0a0d7258aa6e265c
2:31:49 PM: Fetching cached dependencies
2:31:49 PM: Failed to fetch cache, continuing with build
2:31:49 PM: Starting to prepare the repo for build
2:31:49 PM: No cached dependencies found. Cloning fresh repo
2:31:49 PM: git clone --filter=blob:none --no-checkout https://github.com/bolaurent/sonomamatsuri-feeling-responsive
2:31:50 PM: Preparing Git Reference refs/heads/master
2:31:52 PM: Parsing package.json dependencies
2:31:53 PM: Starting build script
2:31:53 PM: Installing dependencies
2:31:53 PM: Python version set to 2.7
2:31:54 PM: Downloading and installing node v10.24.1…
2:31:54 PM: Downloading https://nodejs.org/dist/v10.24.1/node-v10.24.1-linux-x64.tar.xz
2:31:54 PM: Computing checksum with sha256sum
2:31:54 PM: Checksums matched!
2:31:56 PM: Now using node v10.24.1 (npm v6.14.12)
2:31:56 PM: Started restoring cached build plugins
2:31:56 PM: Finished restoring cached build plugins
2:31:56 PM: Attempting Ruby version 2.6.2, read from environment
2:31:57 PM: Required ruby-2.6.2 is not installed - installing.
2:31:57 PM: Searching for binary rubies, this might take some time.
2:31:57 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/20.04/x86_64/ruby-2.6.2.tar.bz2
2:31:57 PM: Checking requirements for ubuntu.
2:31:57 PM: Requirements installation successful.
2:31:57 PM: ruby-2.6.2 - #configure
2:31:57 PM: ruby-2.6.2 - #download
2:31:57 PM: ruby-2.6.2 - #validate archive
2:32:02 PM: ruby-2.6.2 - #extract
2:32:05 PM: ruby-2.6.2 - #validate binary
2:32:05 PM: ruby-2.6.2 - #setup
2:32:05 PM: ruby-2.6.2 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.6.2@global
2:32:05 PM: ruby-2.6.2 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems…
2:32:06 PM: ruby-2.6.2 - #generating global wrappers…
2:32:06 PM: ruby-2.6.2 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.6.2
2:32:06 PM: ruby-2.6.2 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
2:32:06 PM: ruby-2.6.2 - #generating default wrappers…
2:32:06 PM: Using /opt/buildhome/.rvm/gems/ruby-2.6.2
2:32:06 PM: Using Ruby version 2.6.2
2:32:07 PM: Using PHP version 8.0
2:32:07 PM: Started restoring cached ruby gems
2:32:07 PM: Finished restoring cached ruby gems
2:32:07 PM: Installing gem bundle
2:32:08 PM: Fetching gem metadata from https://rubygems.org/
2:32:08 PM: Fetching gem metadata from https://rubygems.org/.
2:32:08 PM: Resolving dependencies…
2:32:08 PM: sass-embedded-1.57.1-x86_64-linux-gnu requires rubygems version >= 3.3.22, which
2:32:08 PM: is incompatible with the current version, 3.0.8
2:32:08 PM: Error during gem install
2:32:08 PM: Build was terminated: Build script returned non-zero exit code: 1
2:32:09 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1 (Search results for '"non-zero exit code: 1"' - Netlify Support Forums)
2:32:08 PM: Failing build: Failed to build site
2:32:09 PM: Finished processing build request in 19.749s

Gemfile contains:

source 'https://rubygems.org'

gem 'jekyll'

group :jekyll_plugins do
  gem 'jekyll-gist'
  gem 'jekyll-paginate'
  gem "jekyll-asciidoc"
  gem 'jekyll-algolia'
  gem 'jekyll-environment-variables'
end

gem 'asciidoctor', '~> 1.5.4'
gem 'coderay', '1.1.1'


gem "webrick", "~> 1.7"

Gemfile.lock content:

GEM
  remote: https://rubygems.org/
  specs:
    addressable (2.8.1)
      public_suffix (>= 2.0.2, < 6.0)
    algolia_html_extractor (2.6.4)
      json (~> 2.0)
      nokogiri (~> 1.10)
    algoliasearch (1.27.5)
      httpclient (~> 2.8, >= 2.8.3)
      json (>= 1.5.1)
    asciidoctor (1.5.8)
    coderay (1.1.1)
    colorator (1.1.0)
    concurrent-ruby (1.1.10)
    em-websocket (0.5.3)
      eventmachine (>= 0.12.9)
      http_parser.rb (~> 0)
    eventmachine (1.2.7)
    faraday (2.7.4)
      faraday-net_http (>= 2.0, < 3.1)
      ruby2_keywords (>= 0.0.4)
    faraday-net_http (3.0.2)
    ffi (1.15.5)
    filesize (0.2.0)
    forwardable-extended (2.6.0)
    google-protobuf (3.21.12)
    http_parser.rb (0.8.0)
    httpclient (2.8.3)
    i18n (1.12.0)
      concurrent-ruby (~> 1.0)
    jekyll (4.3.2)
      addressable (~> 2.4)
      colorator (~> 1.0)
      em-websocket (~> 0.5)
      i18n (~> 1.0)
      jekyll-sass-converter (>= 2.0, < 4.0)
      jekyll-watch (~> 2.0)
      kramdown (~> 2.3, >= 2.3.1)
      kramdown-parser-gfm (~> 1.0)
      liquid (~> 4.0)
      mercenary (>= 0.3.6, < 0.5)
      pathutil (~> 0.9)
      rouge (>= 3.0, < 5.0)
      safe_yaml (~> 1.0)
      terminal-table (>= 1.8, < 4.0)
      webrick (~> 1.7)
    jekyll-algolia (1.7.1)
      algolia_html_extractor (~> 2.6)
      algoliasearch (~> 1.26)
      filesize (~> 0.1)
      jekyll (>= 3.6, < 5.0)
      json (~> 2.0)
      nokogiri (~> 1.6)
      progressbar (~> 1.9)
      verbal_expressions (~> 0.1.5)
    jekyll-asciidoc (3.0.0)
      asciidoctor (>= 1.5.0)
      jekyll (>= 3.0.0)
    jekyll-environment-variables (1.0.1)
      jekyll (>= 3.0, < 5.x)
    jekyll-gist (1.5.0)
      octokit (~> 4.2)
    jekyll-paginate (1.1.0)
    jekyll-sass-converter (3.0.0)
      sass-embedded (~> 1.54)
    jekyll-watch (2.2.1)
      listen (~> 3.0)
    json (2.6.3)
    kramdown (2.4.0)
      rexml
    kramdown-parser-gfm (1.1.0)
      kramdown (~> 2.0)
    liquid (4.0.4)
    listen (3.8.0)
      rb-fsevent (~> 0.10, >= 0.10.3)
      rb-inotify (~> 0.9, >= 0.9.10)
    mercenary (0.4.0)
    nokogiri (1.14.0-arm64-darwin)
      racc (~> 1.4)
    octokit (4.25.1)
      faraday (>= 1, < 3)
      sawyer (~> 0.9)
    pathutil (0.16.2)
      forwardable-extended (~> 2.6)
    progressbar (1.11.0)
    public_suffix (5.0.1)
    racc (1.6.2)
    rb-fsevent (0.11.2)
    rb-inotify (0.10.1)
      ffi (~> 1.0)
    rexml (3.2.5)
    rouge (4.0.1)
    ruby2_keywords (0.0.5)
    safe_yaml (1.0.5)
    sass-embedded (1.57.1-arm64-darwin)
      google-protobuf (~> 3.21)
    sawyer (0.9.2)
      addressable (>= 2.3.5)
      faraday (>= 0.17.3, < 3)
    terminal-table (3.0.2)
      unicode-display_width (>= 1.1.1, < 3)
    unicode-display_width (2.4.2)
    verbal_expressions (0.1.5)
    webrick (1.7.0)

PLATFORMS
  arm64-darwin-21

DEPENDENCIES
  asciidoctor (~> 1.5.4)
  coderay (= 1.1.1)
  jekyll
  jekyll-algolia
  jekyll-asciidoc
  jekyll-environment-variables
  jekyll-gist
  jekyll-paginate
  webrick (~> 1.7)

BUNDLED WITH
   2.3.11

This did not help:

bo@Bos-Mac-mini sonomamatsuri-feeling-responsive % gem update --system
Latest version already installed. Done.
bo@Bos-Mac-mini sonomamatsuri-feeling-responsive % 

I was able to fix this by adding the following line to gemfile (and then running bundle install):

gem "jekyll-sass-converter", "~> 2.0"

I figured this out at this Jekyll PR:

1 Like