Deployment Failed - rubygems incompatibility issue

netlify site name: mamazilla
deployment fails at Initializing step with the following

requires rubygems version >= 3.3.22, which is incompatible with the current version, 3.1.2

My gemfile is setup like this

source “

gem “jekyll”, “~> 4.3.2”
gem “json-minify”, “~> 0.0.3”
gem “jekyll-sass-converter”, “~> 2.0”

group :jekyll_plugins do
gem ‘jekyll-feed’, “~> 0.12”
gem ‘jekyll-sitemap’
gem ‘jekyll-paginate-v2’

I had this issue in the past and changed the sass-converter line as this was solving the problem but now the build started failing again. Any ideas on how to fix this?

I fixed it by forcing a lower version for ffi in my Gem file

gem “ffi”, “= 1.16.3”

If you start getting failures locally run bundle clean --force

Solution found here: Jekyll Build failing for Github pages site · community · Discussion #127006 · GitHub

Hi @idroulia,

Thanks for reaching out and then updating with your solution. Glad to hear you were able to solve it.