Can’t run Jekyll 4 because rubygems version <2.7.0


I run Jekyll 4.0.0 locally.

I’m setting Ruby to v 2.4.3 in .ruby-version but all Netlify builds are failing with jekyll-4.0.0 requires rubygems version >= 2.7.0, which is incompatible with the current version, 2.6.14

Locally, I have rubygems 3.0.6

Is there anyway to get Netlify to run >=2.7.0?



Thanks @talves,

Not sure editing gemfile.lock is the right approach? My limited knowledge of Bundler is that you edit gemfile in order to generate gemfile.lock

I was hoping I could add something like require "rubygems", "2.7.0" or similar to gemfile, but that’s not possible (which makes sense).

So I’m guessing this is a Netlify environment thing rather than anything I can do?


Leon (sorry, different account, at work now!)

It may be a Netlify issue, Leon; hard to say without more details.

We definitely have some hardwired versions of bundler and friends, but they usually depend on ruby version. So: could you try bumping either:


Hi Chris,

I’ve solved this problem. I am using an old Ubuntu version on my Netlify install, but that doesn’t make a difference. However, using Ruby 2.6.3 works, so I assume your Ruby version 2.4.3 comes with a too old version of rubygems for Jekyll 4.

Incidentally, your Ubuntu image comes with Ruby 2.6.2 pre-installed, so that’s probably a better choice to avoid installing 2.6.3 every build.

Thanks for the suggestion – I probably should have figured this out!



1 Like

thanks for keeping us updated, leon!