Remix app throws 404 error upon deployment

PLEASE help us help you by writing a good post!

wagwan. I’ve been tryna deploy a remix app to netlify with the following netlify.toml config file:
command = “remix build”
publish = “public”

from = “/*”
to = “/.netlify/functions/server”
status = 200

for = “/build/*”
“Cache-Control” = “public, max-age=31536000, s-maxage=31536000”

but whenever I run netlify deploy I get 404 errors from the page. The biggest problem seems to be the fact that the deployment logs skip every step besides “post-processing”. Now I’ve tried looking at the remix-netlify template git repo, I DID NOT get very far in that aspect.

Here are the most recent log files, verbatim:
11:24:40 PM: Post processing - redirect rules

11:24:40 PM: Starting post processing

11:24:40 PM: Skipping form detection

11:24:40 PM: Post processing - header rules

11:24:40 PM: Post processing done

11:24:40 PM: Section completed: postprocessing

11:24:40 PM: Site is live :sparkles:

Before you ask, yes I built my public and build, dist files, yes everything works perfectly fine on localhost, and I’m using TS if that has anything to do with it.


quoting netlify docs:

Update the deploy target for an existing Remix app

If you have an existing Remix project that isn’t deployed on Netlify and you want to change the deploy target to Netlify, you need to create a new Remix project.

  1. Create a new Remix project with Netlify as the deploy target.
  2. Replace the new project’s app directory with the app directory from your old project.

so just use vercel, AWS or GCP.

“copy files to new folder” funny asl tho, good luck yaw.