Greenfield remix app not uploading proper files to run

Trying to deploy any greenfield remix app using the netlify CLI

  • this is the indie stack version, but every stack yields the same results
  • regardless of what type of remix app I create (indie stack, vanilla remix, kpop stack) no matter what there’s nothing deployed. some files when I download to see but nothing that works.

I can’t find that any suggestions help. I haven’t changed anything in any of the stacks.

Hi @jamesholbert, thanks for the post.
If you have not already visited the Netlify blog below, kindly check Netlify blog on how to properly deploy Remix applications on Netlify.

Let me know the outcome.


Thanks for getting back to me. I’ve tried that, the latter portion with the CLI commands, and I always get the same result. Maybe something has changed?

Hi @jamesholbert, thanks for the extra feedback.

Since you are still encountering problems using the Netlify CLI for deployment, kindly try out the Official Remix Documentation page on deploying your Remix application at the link below.


Yeah I’ve tried that too. It seems that Netlify is just not working as an option at all.

Would you (or another netlify rep) mind spinning up a vanilla remix app and trying to deploy using the CLI? It’s just not working and that seems worth investigating.

Hi @jamesholbert, I tried to deploy a new remix application from my GitHub repository and it works as expected.
Make sure the netlify.toml in your root folder has the content similar to the code below.

  command = "remix build"
  publish = "public"

  command = "remix watch"
  port = 3000

  from = "/*"
  to = "/.netlify/functions/server"
  status = 200

  for = "/build/*"
    "Cache-Control" = "public, max-age=31536000, s-maxage=31536000"

If the above does not work, a good place to start to investigate is to look at your deploy logs for possible deployment errors.

Hope the above helps.

Thanks for getting back to me again. We don’t use github at my place of work, we have a self hosted gitlab, so I need to be able to deploy from the command line, but it’s not working.

Hi @jamesholbert, thanks for the feedback.

The Netlify CLI should deploy your project without any issues.

At this point it will be difficult to tell what might be causing the problem since you are using a self hosted GitLab.

However if there any errors in your console or terminal when you try to deploy using the Netlify CLI kindly share.
Also if possible create a new vanilla Remix application and then deploy to see if it will work.

If the vanilla Remix deployment does not work then you can narrow down the problem to your environment. You can either upgrade your Netlify CLI or delete and then reinstall again to see if it solves the problem.

Hey @clarnx

But it’s not working. I have an up to date netlify CLI, and I haven’t even gotten to gitlab yet, I’m just trying to deploy from the command line locally. Greenfield project, without any changes yet. I cloned the vanilla stack and the indie stack but were unable to deploy to netlify. I gave you a link at the very beginning to one of the projects and the results there.

Hi @jamesholbert, sorry to hear that you have tried everything and it is still not working.

However, kindly watch the video below on how to deploy a Remix project locally using the Netlify CLI from the Official Remix YouTube Channel if you have not done so already.

Also I kindly ask that you follow the video step by step so that you don’t miss any step. You can also view the steps in the file in your project.

Let me know the outcome.


1 Like