Redirect not working - Netlify recognises the rule

Hey! So I have had this redirect in place since February, no issue until a few days ago.

The redirect works for the but not for the main domain of

# Redirects from what the browser requests to what we serve* 301!* 301!*  301!

I am pulling my hair out over this >.<

Actually, you should change “” to “” to prevent more roundtrips.

Did you add your _redirects to the “” server too? It doesn’t seem to be the case.

Depending on your needs, I’d consider (if not recommend!) using “:splat 301!” on your root domain.

Edited it to all this, still only working on the netlify domain :frowning:

Is hosted on the same Netlify account? If they are separated, you must upload redirect file to this account too (just drop a folder with an index.html and the _redirects file).

All hosted on the same account. All I have is the redirect and the index.html in there. Nothing has been touched since February

Then, I give up, this is so weird!

Somebody from the Netlify team will have a look and find the cause.

That’s the same point I got to haha! Thanks for helping!

1 Like

@lee.pearson Hmm, bowlerspet redirects to for me here in Arizona.

For me too, it does redirect as of today! It looks like some DNS thingies not updated or some glitches… @lee.pearson

I put in a javascript redirect for the time being as a quick fix! The netlify redirect still doesn’t work! I just didn’t want more customer complaints over the weekend

Hey @lee.pearson,
Very weird! One thing we can do to simplify a bit since you’re redirecting everything to the same place is: would you mind replacing your current redirects with this one?

/*   301!

This should redirect requests to all domains associated with your site (so,,, and to Please let me know if that doesn’t work and we’ll dig in further.

Thanks for the simplification!

Sadly the redirect still doesn’t work on the primary domain :frowning: I’m going to add in the JS again for now

Hey @lee.pearson,

Sucks that we haven’t got it working yet. If you like, if you could provide us with a recent deploy log where the redirects fail, we can see what’s happening from our end.

Similarly, you might find value in checking out our redirects support guide.

Hey @lee.pearson :wave:t2:

I’ve actually just wired up a few of my domains the way I believe you’re trying to yesterday, so hopefully I can help you nail this down. I do see your js-redirect on (httpie) -

jon-fm(master): http
GET / HTTP/1.1
Accept: */*
Accept-Encoding: gzip, deflate
Connection: keep-alive
User-Agent: HTTPie/2.1.0

HTTP/1.1 200 OK
Age: 0
Cache-Control: public, max-age=0, must-revalidate
Connection: keep-alive
Content-Length: 209
Content-Type: text/html; charset=UTF-8
Date: Fri, 05 Jun 2020 16:31:32 GMT
Etag: "efbffa40c1e83a7ab3e04536b96be0f6-ssl"
Server: Netlify
Strict-Transport-Security: max-age=31536000
X-NF-Request-ID: 6043fe85-8855-40c4-baa7-816c41d9816a-419944

<!DOCTYPE html>
    <meta charset="UTF-8">


but I also see your redirect from the Netlify subdomain to the primary domain working fine too (:+1:t2:) so I’m with you where you’re at.

Can you give me some context around the site breakdown on Netlify? Is this two separate Netlify Sites? And which one has which domain(s) applied to that site?

Given those answers, we can rock it out :+1:t2: