Redirect error on Google Search console for non-https bare URL

It’s definitely possible it’s on my side, especially as it seems to be a different error than others are encountering. I re-enabled prerendering on my site, and I can live without searchability for a little longer.

Steps to reproduce:

  • Visit https://www.pdfstitcher.org with a bot user agent, such as Googlebot or LinkedInBot (e.g. curl -svo /dev/null -A Googlebot https://www.pdfstitcher.org
  • Response is 504 gateway timeout
  • Response without user agent override is 200
  • Response when connecting directly to netlify subdomain is also 200 (curl -svo /dev/null -A Googlebot https://brave-volhard-5d9df5.netlify.app)
  • Github repo is public at GitHub - cfcurtis/pdfstitcher-org: Website for pdfstitcher

I apologise if it is a problem on my end, I’m new to web development and have mostly just modified a template so far. The part where it works on the netlify subdomain but not my custom domain is really confusing to me.

I just tested your site with the prerendering service run locally and I do see that your site does timeout (returning a 504) with our prerender.

I don’t any insight into what your site does so I don’t know why it is timing out. You might be able to debug this by testing it yourself. The instructions to do this can be found here:

Note, deleting the line with server.use(prerender.basicAuth()); in server.js is typically required to get the service running locally.

This other forum topic might be helpful as well:

To summarize, your issue is not related to the other issues above and is instead a timeout of the prerendering service due to something specific about your site.

If there are other questions please let us know.

Thank you for looking in to this, I will disable prerendering for now and investigate locally. I thought it couldn’t be a local problem because it worked with the netlify subdomain but not my custom domain, but evidently I have a lot to learn.

1 Like

Hi Luke, it doesn’t look to be resolved on my end. Is there anything else I need to do, aside from requesting another validation from Google?

Hi, @Duo-Studio. We can take a look to see if it is the same issue or not. If it is the same issue (meaning this bug isn’t actually fixed) we will reopen the issue and get it developer attention.

To do this, I need to confirm what is happening. Would you please send us the URL which isn’t redirecting correctly?

You can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

@Duo-Studio, would you please also confirm if you are seeing a redirect loop or a 504 status issue?

I also want to clarify that, while @cfcurtis was seeing an issue with the prerendering service returning a 504 response for their site, it wasn’t the same issue as the redirect loop originally being reported. (We try to keep topics (aka “posts”) limited to a single topic (yes, I said we keep “topics to a single topic”.)

@cfcurtis if you do want to troubleshoot the 504 issue further, would you please create a new topic for that? We are happy to assist with additional troubleshooting (or maybe a Netlify Pilot or other forum member will assist). We just want to keep each issue being discussed in its own topic.

Hi, @Duo-Studio. I got the PM information from you. I’m replacing the real apex domain with example.com. Whenever I write example.com just replace that with the real apex domain you sent me.

The information you send doesn’t show a redirect loop. It shows a 301 redirect from https://www.example.com/ to the primary custom domain of https://example.com/ which returns a 200 response. That isn’t a redirect loop. That is one redirect and a 200 status. There is no loop at all.

I thought maybe you were seeing the redirect look in some other way but nothing I tested triggered any looping behavior (using HTTP only, starting at the apex, using a prerender user-agent - nothing I tried would trigger a loop).

Would you please confirm the loop that you are seeing? Again, you can PM that or post it here using example.com and we can replace that with the real apex domain when testing.