Home
Support Forums

Redirect error on Google Search console for non-https bare URL

Hi,

I’m receiving a redirect error on Google Search console for one of my pages for the site lightmeterultra.netlify.app:

For the page http://lightmeterultra.com I get a ‘Redirect error’ in Google search console, even though it appears to me to be redirecting to the canonical page of https://www.lightmeterultra.com.

Any ideas? Is this an issue with my config?

Many thanks,

EDIT: Also, not sure if relevant, but the domain was recently moved from ultrafinelabs.com to lightmeterultra.com.

3 Likes

Hi, I’m having a similar issue. I have an app that has been running for couple of months and everything seemed to be fine. It’s redirecting from http to https and even when I run lighthouse audit it says that the redirect happens. But now Google Search Console is complaining about a redirect error even though I have not changed anything since I deployed my site.

Could someone help us on this issue, please? Thanks

3 Likes

Hi @Ultra and @eduardo.hosoume

Is the error the same as this forum post? Google Search redirect error started last week (no change to my site)

I’m not sure. It’s certainly similar.

In my case I have no issues reported with the http://www.lightmeterultra.com/https://www.lightmeterultra.com/ redirect, only the http://lightmeterultra.com/https://www.lightmeterultra.com/ redirect.

Update on this: I just tried the redirect checker at Redirect Checker | Check your Statuscode 301 vs 302. (I don’t know much about this tool – I found it via a Google search.)

The default configuration for http://lightmeterultra.com reports that everything is fine.

However, changing the user agent to GoogleBot causes infinite redirects.

Could it be related?

@Ultra Welcome to the Netlify community.

Your domain seems to be redirecting properly:

| ---------------------------- http -----------------------------
| --------------------- lightmeterultra.com ---------------------
HTTP/1.1 301 Moved Permanently
cache-control: public, max-age=0, must-revalidate
content-length: 43
content-type: text/plain
date: Sun, 09 May 2021 12:25:43 GMT
x-nf-language: 
location: https://lightmeterultra.com/
x-nf-ats-version: 3438f24
age: 408
x-nf-request-id: 2ed98da8-5231-4ad4-ac8e-79aeda38fe20
server: Netlify
x-nf-country: US

HTTP/2 301 
cache-control: public, max-age=0, must-revalidate
content-length: 47
content-type: text/plain
date: Sun, 09 May 2021 12:27:07 GMT
strict-transport-security: max-age=31536000
x-nf-language: 
location: https://www.lightmeterultra.com/
x-nf-ats-version: 3438f24
x-nf-request-id: 0a106b30-4748-42c9-ae97-0e977aadf548
age: 325
x-nf-country: US
server: Netlify

HTTP/2 200 
cache-control: public, max-age=0, must-revalidate
content-length: 0
content-type: text/html; charset=UTF-8
date: Sun, 09 May 2021 12:32:32 GMT
etag: "505dfdd921daae81ff03a896352d413d-ssl"
strict-transport-security: max-age=31536000
x-nf-language: 
x-nf-ats-version: 3438f24
server: Netlify
age: 0
x-nf-country: US
x-nf-request-id: a1189526-05ae-49a7-b84e-93461ee8b959

However, you seem not to have the A record for your apex domain pointing to the Netlify load balancer IP address, which can cause problems.

|====================== dig A record(s) for =====================
| --------------------- lightmeterultra.com ---------------------
| ---------- Netlify's old load balancer: 104.198.14.52 ---------
| ------------ Netlify's new load balancer: 75.2.60.5 -----------
52.73.87.228
64.227.12.111
Organization:   Amazon Technologies Inc. (AT-88-Z)

See the documentation here:
https://docs.netlify.com/domains-https/custom-domains/configure-external-dns/
|================================================================
1 Like

Likely.

The post I shared previously links to an article explaining how Googlebot works => Google on 307/HSTS Redirects (HTTP to HTTPS)

1 Like

@gregraven Thanks for your reply.

I will add this now. I was under the assumption that the alias was all that was required when I ran through the initial set-up.

Is there any reason this doesn’t show as a warning on the Netlify config screen?

Probably because there are cases when the apex domain is not served by Netlify but subdomains are. The docs are pretty clear on how to set up external DNS, though.

That’s interesting. I’m certain the previous recommendation was to use an ‘alias’ record instead of an ‘a’ record. Now it appears the all mention of alias record has been removed?

That would not surprise me. Alias records for apex domain are not part of the DNS specification, and I have seen issues with using them instead of pointing the apex A record to the Netlify load balancer IP address.

2 Likes

Well, mystery solved. Thank you for your help – I’ll be sure to mark you answer as the solution once the DNS propagates and I can retest the url.

1 Like

Hey Ultra, i have kind of the same issue i think. When testing my website http://resetlab.fr/ with googlebot, it’s shows me 19 redirections. I registered the domain at google domains but i use Netlify DNS. Where should I add the A record for apex domain? I tried adding it on netlify but it tells me “dns_api resetlab.fr - resetlab.fr/A: 400 - link exists, all config must be empty”

Thanks for the help in advance

@etiennedesportes Welcome to the Netlify community. Yet another reason not to trust Google, IMHO.

When using Netlify DNS, the A records are handled automatically.

Here’s what I see when checking your custom domain for redirects:

|====================== check for redirects =====================
| ---------------------------- https ----------------------------
| ------------------------- resetlab.fr -------------------------
HTTP/2 200 
cache-control: public, max-age=0, must-revalidate
content-length: 0
content-type: text/html; charset=UTF-8
date: Sat, 15 May 2021 15:42:30 GMT
etag: "1154f1facb8512c8b7a4da235ed26648-ssl"
strict-transport-security: max-age=31536000
age: 0
x-nf-request-id: 153a6584-3a34-40de-9bce-a59c4a9d08d4
server: Netlify


| ---------------------------- https ----------------------------
| ----------------------- www.resetlab.fr -----------------------
HTTP/2 301 
cache-control: public, max-age=0, must-revalidate
content-length: 0
content-type: text/plain
date: Sat, 15 May 2021 15:42:30 GMT
strict-transport-security: max-age=31536000
server: Netlify
location: https://resetlab.fr/
age: 2
x-nf-request-id: 949c5356-107d-4ee5-96dd-fbeada3b8393

HTTP/2 200 
cache-control: public, max-age=0, must-revalidate
content-length: 0
content-type: text/html; charset=UTF-8
date: Sat, 15 May 2021 15:42:31 GMT
etag: "1154f1facb8512c8b7a4da235ed26648-ssl"
strict-transport-security: max-age=31536000
age: 0
x-nf-request-id: 5df83d2f-e953-459a-888d-cb3969b577d7
server: Netlify

|================================================================

Yes google is the only one having the issue it seems when crawling!
So should i just ignore the error in the google search console about the http redirection? Or is there any way to fix it?
Many thanks for the info about A records Greg

@etiennedesportes Far be it from me to advise anyone how to deal with Google, but I doubt there is any way to “fix” this.

1 Like

I use Netlify DNS and experienced this problem today…

So, I read up the docs from netlify about how to set up DNS, according to these docs when you use netlify DNSyou don’t have to do anything… but for external dns for an apex domain you should do this:

  1. Create an A record for your domain.com directing towards IP 75.2.60.5
  2. Create an CNAME record for your www.domain.com directing towards your domain.netlify.app
  3. Set the www.domain.com as PRIMARY domain for your site

Important question is why netlify does not configure apex domain settings according to their own docs automatically while adding new domain to your site while using netlify DNS.
It seems it still does it the ‘old’ way of creating only cname records for both www subdomain as well as the apex domain.com (and therefore now causing errors with google crawling bot ?)

Everything was fine for months and suddently this is an issue, I wonder whether something changed on google or netlify end and who will fix it.

Edit: I also tested the CNAME flattening with another dns provider, still same problem, so it seems something changed on google end and they might no longer accept CNAME flattening.

I guess the ‘fix’ for now in netlify DNS and others would be to stop using CNAME flattening and:

  • remove CNAME domain.com entry pointing towards domain.netlify.app
    and
  • adding A entry pointing towards 75.2.60.5

@pduchnovsky If you are just venting, that’s fine. But if you would like someone else to be able to provide some insight to help resolve this issue, please provide your custom domain name at least.

I don’t need an insight, I tested this and the above mentioned fix is the only thing that worked to get rid of google bot error.

I’ve noticed similar oddities many times before on sites using CNAME flattening, which I why I always recommend trying the combination of A and CNAME records when using external DNS.

Glad you were able to resolve the issue.