Home
Support Forums

React app launches with blank page

Hi there

While I was learning I have recently built my react app using vitejs.dev framework.
In my dev environment its launching and running perfectly but when I am deploying here on Netlify it deploys successfully but on launching site it ends with a blank page.
My site link is : https://quizzical-kirch-6a077f.netlify.app](https://quizzical-kirch-6a077f.netlify.app/
My github Project link : GitHub - vjgaur/web3.0-blockchain-dapp: A Full Stack Web3 Dapp build in React.js Solidity, Ethereum with Metamask Wallet Integration

Before asking for help I tried many alternative solution shared by other community members but none worked for me.

Please help me I don’t get what I am doing wrong

Thanks
Vijendr

You are trying to load a jsx file as a module:

<script type="module" src="/src/main.jsx"></script>

Which is resulting in an error:

Failed to load module script: Expected a JavaScript module script but the server responded with a MIME type of "application/octet-stream". Strict MIME type checking is enforced for module scripts per HTML spec.

It seems your assets are available, but you’re deploying your root instead:
https://quizzical-kirch-6a077f.netlify.app/dist/assets/index.948f00a6.css

Try setting your build folder to dist in the build settings (or netlify.toml, if you’re using that)

1 Like

Hi tom
thanks for guiding me.
After I set the publish path to ./dist it worked. I am able to launch my site now https://web2plus1.netlify.app/

Thanks a lot for the help