Re-running netlify lm:setup

Hi folks,

I’m experimenting with setting up Large Media Support. Locally I ran the migrate with the --everything flag. After a bit of thinking it through, I decided to reset the local branch and migrate over to LFS without using --everything. So I forced reset the local branch, tried again, but got stuck running netlify lm:setup. Specifically:

% netlify lm:setup                                 
  ✖ Provisioning Netlify Large Media
    → Netlify Large Media is already installed for sjifire
    Configuring Git LFS for this site

and I can’t get the .lfsconfig file to be written out again. In hindsight I should have saved the repo, but I also thought that running netlify lm:setup again would work.

Can you help me get unstuck? Do you need to remove large media from my acct and then I can re-set it up? My account is

thank you for your help,

and… I guessed that the .lfsconfig file was https://<SITE-ID>, and I ran a little experiment and it worked. So I’m off and running.

The netlify lm:setup should probably be able to create this file if run again, but at least the workaround was guessable. Let me know if you need any additional information.
thank you!

Thanks for coming back and sharing your solution! This will definitely be beneficial for future Forums members who encounter something similar.

Hi @hillary,

it should probably be fixed at the tooling level to allow lm:setup to run all the way through even if it is already setup on the server side… ie, have that step warn and continue rather than error and stop.


1 Like