Preventing emails being marked as spam

Hi, how would I be able to make my emails I send not be marked as spam by Gmail? I would like to know how to set up a reverse DNS record with my IP. My Netlify site name is Lloyd Develops, and the URL to my site is https://lloyddevelops.com.
Many thanks

It generally depends on your e-mail server. I take it that you’re using some external e-mail server to configure e-mail for your domain. Generally speaking, you should also get a DKIM record, and once you add that to your DNS in Netlify, it should not result in spam. However, it also depends on the e-mail contents. If you still send an e-mail which matches the spam filters of Gmail it’d end up in spam.

Hi, @LloydDevelops. The Netlify support team can answer DNS questions but not questions about email services. This is a question about the email service, not the DNS service.

Netlify doesn’t offer any email service so we are not able to tell you what the “correct” record DNS records to make are. We can assist with creating DNS records but we need you to tell us what records you want to create.

I can give you a best guess and point you in the general direction but I don’t know the specific answers you require. Step one is usually to configure the required SPF, DKIM, and/or DMARC DNS records for the domain.

What records are required? I don’t know and your email service does.

If you create a record and it doesn’t work or if there are questions about how to create a specific record, our support team will be happy to assist.

To summarize, the question you are asking can only be answered by your email service and we are not that service. If you try to create records and have any issues doing so, that we will be happy to assist with.

Hi, I’ve been having the same issue. I managed to get my domain (on 123-reg) to point to my Netlify website, but now some emails getting sent straight to spam folders, so I went to my email provider (also 123-reg) to add a DKIM record, but it says the following:

" To set up a DKIM (DomainKeys Identified Mail) record on your domain name, please do the following:

Firstly, you need to ensure your domain is pointed to the 123 Reg nameservers.

If the domain is not pointed to the 123 Reg nameservers, you will be unable to manage them from the 123 Reg control panel."

But…if I change the Nameserver config back to 123-reg from dns1.p07.nsone.net etc… isn’t that going to prevent them pointing to Netlify?

Sorry if this is an obvious question…I feel like I’m going around in circles here.

Hi, @HyperLathe. You can use Netlify DNS server or your registrar’s names servers. Those are two different configuration and both will work:

You can create the DKIM record using Netlify DNS also. To do so, create the same record as in the 123 Reg instructions but make that record at Netlify instead of making it at 123 Reg.

If there are other questions about this, please let us know.

1 Like

Thanks so much! I’ll give one of those a go.

Hi Luke,

Sorry but I’m still having issues (with my emails getting sent to clients’ spam filters). My domain / email provider is 123-reg, and I have currently set the Netlify DNS settings as below, after setting both the SPF and DKIM records. Can you see anything obvious that I’ve missed? Thank you.

Hi, @HyperLathe. That’s just it. I don’t know what DNS records your email service requires or why emails are being sent to a spam filter. I have zero visibility into the operation of those email systems.

I can test the DNS service only. I do see all the records above working when I query for them:

hyperlathe.com.		3599	IN	MX	10 mx0.123-reg.co.uk.
hyperlathe.com.		3599	IN	MX	20 mx1.123-reg.co.uk.
hyperlathe.com.		19	IN	A	138.197.207.178
www.hyperlathe.com.	19	IN	A	138.68.60.208
hyperlathe.com.		3599	IN	SPF	"v=spf1 mx a ip4:94.136.40.163 a:mailex.mailcore.me -all"
dkim._domainkey.hyperlathe.com.	3599 IN	TXT	"v=DKIM1;t=s;p=MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDDJYnnwSICxj5JUCbWtcag53JAfyYq0ZjZJmlD8NtejFa/7s3dHS84+s3ldC0bHyWCL6oBDE//UEvgSo0nh0gpu8seu13pKxXw4arScmhNqR7BvrIjtSJoaLqtP3aIHc67WYSKjWVMW0c3dm5wCqckiEkJHVd/Lfdhx6U8t92/JwIDAQAB"

(The NETLIFY type records return geographic location specific IP addresses for the “closest” ADN nodes - the two A records above.)

So, are the records present and do they work correctly? That is a question I can answer and, yes, they do work as entered.

There is another question:

  • Are those the correct records and if not what records do I need?

For that question, I have no idea and no way to answer it.

This is information we at Netlify simply do not have. We don’t run your email services - only the DNS service. We cannot help you configure the email service because we don’t know anything about it. You need to tell us what the correct records are.

Once you tell us what the correct records are, we can give instructions to explain how to create those records at Netlify. We can also test them and confirm if they are working or not like I did above.

On the other hand, if you don’t know what the correct records are, then you would need to contact the technical support for the email service. The email service provider has the information about what DNS records are required for email services to work and we do not.

Note, the 123 Reg instructions seem to only explain what do to if you use their DNS service. You can revert to their DNS and not use Netlify DNS for the domain. That might be the best solution. If you do this, you can still connect the custom domain to the site at Netlify using these instructions (the instructions for using a third-party DNS service):

If there are questions about how to create a specific DNS record or if you created a record and it isn’t working, please let us know. Likewise, if there are questions about how to revert to the 123 Reg DNS service we will be happy to answer.

1 Like

Thank you again for your help. After some trial and error, it turns out out it was a simple matter of changing the SPF record type in the DNS records from ‘SPF’ to ‘TXT’. Now they’re not getting sent to spam folders.

Hi, @HyperLathe. Thank you for taking the time to loop back here to share the solution you discovered.

This will hopefully provide answers for someone searching for a solution to similar issues in the future (and preventing “the denvercoder9 scenario”).

1 Like