OpenSSL Issues Preventing Deployment

NOTE: I was able to get our deployments to work by manually triggering a new deployment (with cleared cache) but I’m still posting this for posterity in case it’s useful to Netlify or someone else.

Site: poacher-crab-40087
Failed Deployment: 5de91ee35961170008c3720f

This is a Jekyll site. We actually had three consecutive deployments fail for this same reason: “Could not load OpenSSL. You must recompile Ruby with OpenSSL support or change the sources in your Gemfile from ‘https’ to ‘http’.”

Here’s a screenshot of the relevant logs:

Good catch on figuring out that a cacheless deploy worked. If it fails to work with cache the next time, please do follow up and we’ll be happy to reinvestigate. It’s pretty hard for us to tell what exactly may have been in your cache at the time of the failures, but it was quite a lot:

7:14:46 AM: Starting to download cache of 1.2GB

and it isn’t a big surprise that something could go sideways there, but that is why we give you the clear cache option on triggering a new deploy :slight_smile:

Good to know! Is there any way to automate that cache clearing? Or is that something we just need to pay attention to and clear out manually every so often?

@pete, at this time, the manual cache clearing is the only method. This is also likely technically possible to do programmatically via our API as well, but I have no prior art for that and haven’t tested it personally.